Когда я устанавливаю транспортир, я получаю такую ​​ошибку:

C:\Users\andreir\AppData\Roaming\npm\node_modules\protractor\node_modules\selenium-webdriver\node_modules\ws\node_modules\utf-8-validate>node "C:\Program Files\nodejs\node_modules\npm\bin\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild
Building the projects in this solution one at a time. To enable parallel build, please add the "/m" switch.
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.Cpp.InvalidPlatform.Targets(23,7): error MSB8007: The Platform for project 'validation.vcxproj' is invalid. Platform='x64'. You may be seeing this message because you are trying to build a project without a solution file, and have specified a non-default Platform that doesn't exist for this project. [C:\Users\andreir\AppData\Roaming\npm\node_modules\protractor\node_modules\selenium-webdriver\node_modules\ws\node_modules\utf-8-validate\build\validation.vcxproj]
gyp ERR! build error
gyp ERR! stack Error: `C:\Windows\Microsoft.NET\Framework\v4.0.30319\msbuild.exe` failed with exit code: 1
gyp ERR! stack     at ChildProcess.onExit (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\build.js:267:23)
gyp ERR! stack     at ChildProcess.emit (events.js:98:17)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (child_process.js:820:12)
gyp ERR! System Windows_NT 6.2.9200
gyp ERR! command "node" "C:\\Program Files\\nodejs\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild"
gyp ERR! cwd C:\Users\andreir\AppData\Roaming\npm\node_modules\protractor\node_modules\selenium-webdriver\node_modules\ws\node_modules\utf-8-validate
gyp ERR! node -v v0.10.38
gyp ERR! node-gyp -v v1.0.1
gyp ERR! not ok

Я не понимаю, где эрорр ...

Имею (актуально): Windows 8.1 pro x64, Python 2.7.10, VS 2012 Pro

2
Andrew 28 Май 2015 в 09:12

1 ответ

Лучший ответ

Проблема, как говорится в ошибке, связана с компиляцией модуля utf-8-validate, требуемого для WebSocket, требуемого для selenium-webdriver

node_modules\protractor\node_modules\selenium-webdriver\node_modules\ws\node_modules\utf-8-validate

Компилятор не может найти конфигурацию проекта для x64

The Platform for project 'validation.vcxproj' is invalid. Platform='x64'

В этой проблеме Github решением была переустановка VisualStudio и Windows SDK.

В любом случае это необязательная зависимость, поэтому вы можете обойтись без нее, пока разбираетесь с ней, запустив

npm install --no-optional
4
SharpEdge 28 Май 2015 в 10:57
Помогла установка VS2010. Спасибо!
 – 
Andrew
16 Июн 2015 в 11:22