Ниже мой пакет.

{ "name": "wallpaper_rn", "version": "0.1.0", "private": true, "devDependencies": { "babel-preset-react-native-stage-0": "^1.0.1", "jest": "^23.6.0", "jest-react-native": "^18.0.0", "react-test-renderer": "16.3.1" }, "scripts": { "start": "react-native start", "android": "react-native run-android", "ios": "react-native run-ios", "test": "jest" }, "jest": { "preset": "react-native" }, "dependencies": { "prop-types": "^15.6.2", "react": "16.4.1", "react-native": "~0.55.2", "react-native-admob": "^2.0.0-beta.5", "react-native-elements": "^0.19.1", "react-native-fetch-blob": "^0.10.8", "react-native-fs": "^2.11.17", "react-native-share": "^1.1.2", "react-native-splash-screen": "^3.1.1", "react-native-swiper": "^1.5.13", "react-native-vector-icons": "^5.0.0", "react-navigation": "^2.14.1", "react-redux": "^5.0.7", "recyclerlistview": "^1.3.4", "redux": "^4.0.0", "redux-thunk": "^2.3.0" } }

Я также пробовал версию react-native-admob (1.3.2).

Я только что установил модуль admob и связал его. После этого приложение внезапно начало вылетать при запуске даже в режиме отладки.

-1
Sanket Lathiya 8 Окт 2018 в 13:02

2 ответа

Лучший ответ

После некоторого поиска я понял, что 2 октября 2018 г. Google обновил некоторые библиотеки, вызвавшие эту ошибку. Я изменил файл android / build.gradle:

compile 'com.google.android.gms:play-services-ads:+'

Кому

compile 'com.google.android.gms:play-services-ads:15.0.0'

И это решило проблему.

1
halfer 8 Окт 2018 в 11:35

Добавьте эту строку в свой проект AndroidManifest.xml

Внутри <application>

<meta-data android:name="com.google.android.gms.ads.APPLICATION_ID" android:value="[appid here]"/>

Ссылка: https://github.com/sbugert/react- нативной AdMob / вопросы / 370 # issuecomment - 429322754

0
Md. Robi Ullah 4 Фев 2020 в 14:05