Я не могу решить эту проблему, пожалуйста, помогите мне! У меня следующая ошибка:

Could not find com.android.support:appcompat-v7:28.0.3.
Searched in the following locations:
    file:/C:/invincible/extras/m2repository/com/android/support/appcompat-v7/28.0.3/appcompat-v7-28.0.3.pom
    file:/C:/invincible/extras/m2repository/com/android/support/appcompat-v7/28.0.3/appcompat-v7-28.0.3.jar
    file:/C:/invincible/extras/google/m2repository/com/android/support/appcompat-v7/28.0.3/appcompat-v7-28.0.3.pom
    file:/C:/invincible/extras/google/m2repository/com/android/support/appcompat-v7/28.0.3/appcompat-v7-28.0.3.jar
    file:/C:/invincible/extras/android/m2repository/com/android/support/appcompat-v7/28.0.3/appcompat-v7-28.0.3.pom
    file:/C:/invincible/extras/android/m2repository/com/android/support/appcompat-v7/28.0.3/appcompat-v7-28.0.3.jar
    file:/C:/Program Files/Android/Android Studio/gradle/m2repository/com/android/support/appcompat-v7/28.0.3/appcompat-v7-28.0.3.pom
    file:/C:/Program Files/Android/Android Studio/gradle/m2repository/com/android/support/appcompat-v7/28.0.3/appcompat-v7-28.0.3.jar
    https://dl.google.com/dl/android/maven2/com/android/support/appcompat-v7/28.0.3/appcompat-v7-28.0.3.pom
    https://dl.google.com/dl/android/maven2/com/android/support/appcompat-v7/28.0.3/appcompat-v7-28.0.3.jar
    http://jcenter.bintray.com/com/android/support/appcompat-v7/28.0.3/appcompat-v7-28.0.3.pom
    http://jcenter.bintray.com/com/android/support/appcompat-v7/28.0.3/appcompat-v7-28.0.3.jar
Required by:
    project :app

Please install the Android Support Repository from the Android SDK Manager.
Open Android SDK Manager

Я пытался скачать, но там видно вот это:

{
  "errors" : [ {
    "status" : 404,
    "message" : "Could not find resource"
  } ]
}

А мой build.gradle показывает, что синхронизация проекта Gradle не удалась. Базовая функциональность не будет работать должным образом.

Мой код build.gradle:

***android {
    compileSdkVersion 28
    defaultConfig {
        applicationId "com.example.myapplication"
        minSdkVersion 15
        targetSdkVersion 28
        buildToolsVersion "28.0.3"
        versionCode 1
        versionName "1.0.2"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        customDebugType {
            debuggable true
        }
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
        debug {
            debuggable true
        }
    }
    buildToolsVersion '28.0.3'
    compileOptions {
        sourceCompatibility JavaVersion.VERSION_1_8
        targetCompatibility JavaVersion.VERSION_1_8
    }
    productFlavors {
    }
    dexOptions {
        incremental true
    }
}
dependencies {
    implementation fileTree(include: ['*.jar'], dir: 'libs')
    implementation 'com.android.support:appcompat-v7:28.0.3'
    implementation "com.android.support:support-core-utils:28.0.3"
    implementation 'com.android.support.constraint:constraint-layout:1.1.3'
    implementation 'com.android.support:design:28.0.3'
    implementation 'com.android.support:exifinterface:28.0.3'
    implementation 'com.android.support:support-v4:28.0.3'
    implementation 'com.google.firebase:firebase-core:16.0.4'
    androidTestImplementation 'com.android.support.test:rules:1.0.2'
    implementation 'com.google.android.gms:play-services-maps:16.0.0'
    implementation 'com.google.firebase:firebase-core:16.0.4'
    implementation 'com.android.support:support-media-compat:28.0.3'
    implementation 'com.google.firebase:firebase-auth:16.0.4'
    implementation 'com.google.firebase:firebase-database:16.0.3'
    implementation 'com.google.firebase:firebase-storage:16.0.3'
    implementation 'com.squareup.picasso:picasso:2.71828'
    implementation 'com.google.android.gms:play-services-places:16.0.0'
}
apply plugin: 'com.google.gms.google-services'***

Прошу прощения за мой английский и помогите мне, пожалуйста

6
Амина К. 8 Окт 2018 в 16:39

2 ответа

Лучший ответ

Вы можете заменить эту зависимость

implementation 'com.android.support:appcompat-v7:28.0.3'

С этим

 implementation 'com.android.support:appcompat-v7:28.0.0'

А также удалите эту строку

 buildToolsVersion '28.0.3

Это работа для меня.

2
Vijendra patidar 13 Окт 2018 в 11:17

Вы можете проверить последнюю версию appcompat-v7 здесь: https : //mvnrepository.com/artifact/com.android.support/appcompat-v7 репо = Google
. Итак, вы можете найти только appcompat-v7:28.0.0 .

Вы должны изменить appcompat-v7:28.0.3 на appcompat-v7:28.0.0. Больше ничего.

2
EvgeTymo 1 Ноя 2018 в 06:53