Я переместил свой веб-сайт с одного сервера [иди, папа] на другой [webserver247], и теперь он не работает, я пробовал все, но, похоже, ничего не работает. Он отлично работает на моем предыдущем сервере, но я не понимаю, в чем проблема на этом сервере. Я попытался переписать htaccess, но это тоже не сработало.

Это htaccess из общей папки

<IfModule mod_rewrite.c>
<IfModule mod_negotiation.c>
    Options -MultiViews -Indexes
</IfModule>

RewriteEngine On

# Handle Authorization Header
RewriteCond %{HTTP:Authorization} .
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

# Redirect Trailing Slashes If Not A Folder...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} (.+)/$
RewriteRule ^ %1 [L,R=301]

# Handle Front Controller...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ index.php [L]

И это htaccess в корневой папке

<IfModule mod_rewrite.c>
<IfModule mod_negotiation.c>
    Options -MultiViews -Indexes
</IfModule>

RewriteEngine On

# Handle Authorization Header
RewriteCond %{HTTP:Authorization} .
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

# Redirect Trailing Slashes If Not A Folder...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} (.+)/$
RewriteRule ^ %1 [L,R=301]

# Handle Front Controller...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ index.php [L]

Может ли кто-нибудь помочь мне, я был бы очень признателен. Спасибо

0
Mohd Mobeen 24 Сен 2018 в 15:50

2 ответа

Лучший ответ

Еще раз проверьте наличие файла .env. Перенос серверов есть столько всего, что могло бы быть.

1
George Hanson 24 Сен 2018 в 12:54

Вы можете превратить APP_DEBUG в TRUE в своем файле .env. Это должно позволить вам увидеть возникшую ошибку, чтобы вы могли ее исправить. К сожалению, сложно просто отладить ошибку 500, не зная точно, что именно происходит.

0
Kshux 24 Сен 2018 в 16:22