Я пытаюсь интегрировать функцию входа в Facebook в свое приложение для Android с помощью библиотеки Firebase-UI. Я следую этому руководству - https://firebase.google.com/ Docs / авт / Android / firebaseui ? AuthUser = 0

Но при попытке создать gradle я получаю ошибку ниже:

Библиотека com.google.android.gms: play-services-basement запрашивается различными другими библиотеками в [[15.0.1,15.0.1]], но разрешается до 16.0.1. Отключите плагин и проверьте свое дерево зависимостей с помощью ./gradlew: app: dependencies.

Ниже находится файл build.gradle уровня моего приложения

apply plugin: 'com.android.application'

android {
    compileSdkVersion 28
    defaultConfig {
        applicationId "company.com.mygame"
        minSdkVersion 15
        targetSdkVersion 28
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    implementation 'com.android.support:appcompat-v7:28.0.0'
    implementation 'com.android.support.constraint:constraint-layout:1.1.3'

    implementation 'pl.droidsonroids.gif:android-gif-drawable:1.2.0'

    implementation 'com.facebook.android:facebook-android-sdk:4.37.0'

    implementation 'com.google.firebase:firebase-core:16.0.4'
    implementation 'com.firebaseui:firebase-ui-auth:4.2.0'

    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'com.android.support.test:runner:1.0.2'
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
}

apply plugin: 'com.google.gms.google-services'

Я видел ниже ссылки -

com.google.android.gms: база play-services-Measurement Measurement запрашивается различными другими библиотеками

https://github.com/OneSignal/OneSignal-Gradle-Plugin/issues/37

Но тогда я получаю эту ошибку -

Manifest merger failed : uses-sdk:minSdkVersion 15 cannot be smaller than version 16 declared in library [com.firebaseui:firebase-ui-auth:4.2.0] C:\Users\me\.gradle\caches\transforms-1\files-1.1\firebase-ui-auth-4.2.0.aar\xxx\AndroidManifest.xml as the library might be using APIs not available in 15
    Suggestion: use a compatible library with a minSdk of at most 15,
        or increase this project's minSdk version to at least 16,
        or use tools:overrideLibrary="com.firebase.ui.auth" to force usage (may lead to runtime failures)

Но проблема до сих пор не устранена. Я только начал изучать Android, не знаю, что мне не хватает.

2
Nivedita 8 Окт 2018 в 10:08

2 ответа

Лучший ответ

У меня была такая же проблема

Просто убедитесь, что у вас установлены самые свежие версии всех зависимостей. Я использовал текущие версии для Firebase core и auth.

Последние версии можно получить здесь. Используя последнюю версию на текущий момент:

В app / build.gradle:

 dependencies {
    ...
    // Add these code
    implementation 'com.google.firebase:firebase-core:16.0.8'
    implementation 'com.google.firebase:firebase-auth:16.2.0'
 }

В android / build.gradle:

buildscript {
    ext {
        ...
        minSdkVersion = 16
        ...
    }
}
2
tjungChaniago 4 Апр 2019 в 01:09

Ваша ошибка говорит: uses-sdk:minSdkVersion 15 cannot be smaller than version 16 и ваш build.gradle как minSdkVersion 15. Попробуйте изменить его на 16 и посмотрите, сработает ли это для вас.

Всего наилучшего для изучения андроида. Да прибудет с тобой сила.

Конец связи,

Aashish

1
Nivedita 8 Окт 2018 в 21:11