Я запускаю Eclipse и пытаюсь выполнить описанные здесь шаги для использования Google App Engine.

Я вставил содержимое в консоль при отладке веб-приложения. На сайте Google я следовал инструкциям. Но затем, когда я захожу на localhost:8888/xxxxxx, я получаю сообщение об ошибке.

Пожалуйста, порекомендуйте. Я использую Java 1.5, а на Mac OSX Tiger и Eclipse — Ганимед.

Спасибо.

    2011-04-16 09:41:49.967 java[257] [Java CocoaComponent compatibility mode]: Enabled
    2011-04-16 09:41:49.968 java[257] [Java CocoaComponent compatibility mode]: Setting timeout for SWT to 0.100000
    ********************************************************
    Warning: Future versions of the Dev App Server will require Java 1.6 or later. Please upgrade your JRE.
    ********************************************************
    Apr 15, 2011 9:41:51 PM com.google.apphosting.utils.jetty.JettyLogger info
    INFO: Logging to JettyLogger(null) via com.google.apphosting.utils.jetty.JettyLogger
    Apr 15, 2011 9:41:51 PM com.google.apphosting.utils.config.AppEngineWebXmlReader readAppEngineWebXml
    INFO: Successfully processed /Users/kateswanson/Documents/workspace/AppEngineInterview/war/WEB-INF/appengine-web.xml
    Apr 15, 2011 9:41:51 PM com.google.apphosting.utils.config.AbstractConfigXmlReader readConfigXml
    INFO: Successfully processed /Users/kateswanson/Documents/workspace/AppEngineInterview/war/WEB-INF/web.xml
0
user710587 16 Апр 2011 в 01:52
1
Помимо предупреждения об использовании java 1.6 вместо 1.5, есть ли реальное сообщение об ошибке с трассировкой стека? Я не вижу фактических ошибок в вашем сообщении.
 – 
hooknc
16 Апр 2011 в 02:05
Согласен с другими комментариями здесь; почему вы не используете Java 6 JDK?
 – 
Matt Ball
16 Апр 2011 в 03:05
Я не могу найти Java 6 JDK для Mac OS Tiger
 – 
user710587
16 Апр 2011 в 05:19
Я не знаю, где найти эти ошибки.
 – 
user710587
16 Апр 2011 в 05:20
...Тигр? Вау, это старо (6 лет, в конце месяца). По состоянию на 28 августа 2009 г. Apple прекратила официальную поддержку Tiger. Пришло время обновиться, amigo.
 – 
Matt Ball
16 Апр 2011 в 09:18

1 ответ

Речь идет только о вашей версии Java, это должна быть Java 1.6.

Просто обновите версию Java, и она будет работать нормально.

Удачи

1
Majed 16 Апр 2011 в 02:38