Я добавил новое правило в web. Файл конфигурации для перенаправления на HTTPS. Он работает на локальном хосте, но как только я развернул его в среде Dev, перенаправление не работает. У кого-нибудь есть решение, чтобы решить эту проблему.

<system.webServer>
<rewrite>
<rules>                   
<rule name="Force HTTPS" enabled="true" stopProcessing="true">    
<match url=".*" ignoreCase="false"/>
<conditions logicalGrouping="MatchAny" trackAllCaptures="false">            
<add input="{HTTPS}" pattern="off"/>
</conditions>                 
<action type="Redirect" url="https://{HTTP_HOST}{REQUEST_URI}" redirectType="Permanent"/>       
</rule>                     
</rules>                     
</rewrite>
</system.webServer>
0
Shore Raina 4 Фев 2022 в 11:59

2 ответа

Используйте эту обновленную версию:

<rewrite> 
    <rules> 
    <rule name="HTTPS force" enabled="true" stopProcessing="true"> 
    <match url="(.*)" /> 
        <conditions> 
            <add input="{HTTPS}" pattern="^OFF$" /> 
        </conditions> 
        <action type="Redirect" url="https://{HTTP_HOST}/{R:1}" redirectType="Permanent" /> 
    </rule> 
    </rules> 
</rewrite> 
0
D A 4 Фев 2022 в 12:06
Я пытался не работать
 – 
Shore Raina
4 Фев 2022 в 13:49
Этот код взят с нашего производственного сервера, и, как вы можете видеть, мой ответ аналогичен другому, который был предоставлен. Я думаю, что ваша проблема в другой области...
 – 
D A
4 Фев 2022 в 13:55

В моем решении я использую эту конфигурацию, и она работает:

<rule name="HTTP to HTTPS redirect for all requests" stopProcessing="true">
          <match url="(.*)" />
          <conditions>
                <add input="{HTTPS}" pattern="off" />
          </conditions>
          <action type="Redirect" url="https://{HTTP_HOST}/{R:1}" />
        </rule>

Я надеюсь, что это решение для вас!

0
Appstalden GmbH 4 Фев 2022 в 12:06
Пробовал и этот тоже не работает
 – 
Shore Raina
4 Фев 2022 в 13:49