Я очень мало использовал jQuery UI и не очень хорошо его знаю. Если я возьму книгу по jQuery UI 1.7, будет ли она актуальна (по большей части) для версии 1.8?

0
ashurexm 25 Июн 2010 в 20:59

2 ответа

Лучший ответ

В типичной схеме нумерации версий (xyz) первое число x указывает на основные изменения в API, потенциально несовместимые с предыдущими версиями, множество новых функций и т. Д. Как и в случае с пользовательским интерфейсом jQuery, второе число y указывает незначительные обновления, исправления ошибок, небольшие улучшения и т. д. Если команда jQuery UI следует этому соглашению (что, по-видимому, они и делают), то у вас должно быть все в порядке с книгой 1.7.

С учетом всего сказанного - как только вы изучите основы пользовательского интерфейса jQuery, вы сможете быстро перейти к любым внесенным изменениям. И, воспользовавшись пользовательским интерфейсом jQuery, я не заметил ничего настолько различающегося между этими двумя версиями, что вы не можете изучить 1.7, а затем перейти на 1.8.

1
JasCav 25 Июн 2010 в 17:46

Насколько мне известно, между этими двумя версиями jquery ui нет несовместимых изменений. Версия 1.8 добавляет некоторые новые функции (кнопки, автозаполнение), а также использует более зрелую версию jquery (1.4.2).

Я также сделал обновление с 1.7 до 1.8 в одном из моих проектов, и это работает как шарм.

Итак, если вы хотите изучить jquery, вы можете использовать книгу для 1.7, хотя она также будет узнавать о новых (хороших) функциях.

Вы можете проверить блог jquery для получения более подробной информации.

0
dzida 25 Июн 2010 в 17:40