Когда я собираю свой проект nuxt.js, он выдает дружественную ошибку, которая не очень дружелюбна. Я сделал чистую установку (удалил package.lock и node_modules), установил core-js @ 2 и @ babel / runtime-corejs2, но все же получать эти ошибки.

 ERROR  Failed to compile with 4 errors        friendly-errors 11:29:16

These dependencies were not found:             friendly-errors 11:29:16
                                               friendly-errors 11:29:16
* core-js/library/fn/array/from in ./node_modules/bootstrap-vue/es/utils/array.js
* core-js/library/fn/array/is-array in ./node_modules/bootstrap-vue/es/utils/array.js
* core-js/library/fn/object/assign in ./node_modules/bootstrap-vue/es/utils/object.js
* core-js/library/fn/object/is in ./node_modules/bootstrap-vue/es/utils/object.js
                                               friendly-errors 11:29:16
To install them, you can run: npm install --save core-js/library/fn/array/from core-js/library/fn/array/is-array core-js/library/fn/object/assign core-js/library/fn/object/is
ℹ Waiting for file changes
1
il0v3d0g 1 Май 2019 в 21:42

3 ответа

Лучший ответ

Был ли этот точный вопрос о сборке CI сегодня. Проблема оказалась с использованием v6 узла. Обновление до v9 решило проблему.

Я не эксперт по синтаксису Nuxt, но вы должны попробовать обновить. Для меня это было вопросом обновления:

image: node:6

К

image: node:9

Для моего изображения докера.

0
ErikH 2 Май 2019 в 13:29
npm installl core-js@2 @babel/runtime-corejs2

Исправлю вашу проблему

0
EvilBurrito 28 Фев 2020 в 03:06

Как упоминалось в статье, https://github.com/cdqa-suite/cdQA-annotator/issues/ 37

«npm run serve» из родительской папки, а не папка src выполнит работу

0
Shivanand THANGALAPALLI 29 Дек 2019 в 02:45