Некоторое время мы пользуемся эмуляторами. Внезапно перестали работать на машинах двух разработчиков (но не всех разработчиков). Они пытаются вызвать firebase emulators:start, а затем получают следующее сообщение об ошибке: Error: An unexpected error has occurred.

Мы действительно понятия не имеем, почему это происходит. Мы даже пробовали переделывать инициализацию firebase и инициализацию эмуляторов. Пока ничего из того, что мы пробовали, не помогло. Вот вывод консоли для более подробной информации:

➜  firebase git:(dev-vab) ✗ firebase emulators:start
i  emulators: Starting emulators: functions, firestore, database, hosting, pubsub
⚠  functions: The following emulators are not running, calls to these services from the Functions emulator will affect production: auth
⚠  Your requested "node" version "10" doesn't match your global version "14"
i  firestore: Firestore Emulator logging to firestore-debug.log
i  database: Database Emulator logging to database-debug.log
i  hosting: Serving hosting files from: public
✔  hosting: Local server: http://0.0.0.0:5000
i  pubsub: Pub/Sub Emulator logging to pubsub-debug.log
i  ui: Emulator UI logging to ui-debug.log
i  functions: Watching "/Users/isaacmartin/git_repos/firebase/functions" for Cloud Functions...
✔  functions[updateUser]: firestore function initialized.
✔  functions[handleEventInviteeCreation]: http function initialized (http://0.0.0.0:5001/likemindedly-stage/us-central1/handleEventInviteeCreation).
i  emulators: Shutting down emulators.
i  ui: Stopping Emulator UI
⚠  Emulator UI has exited upon receiving signal: SIGINT
i  functions: Stopping Functions Emulator
i  hosting: Stopping Hosting Emulator
i  database: Stopping Database Emulator
i  firestore: Stopping Firestore Emulator
i  pubsub: Stopping Pub/Sub Emulator
i  hub: Stopping emulator hub
i  logging: Stopping Logging Emulator

Error: An unexpected error has occurred.

Having trouble? Try again or contact support with contents of firebase-debug.log

Теперь вы заметите, что мы проверили журнал отладки и обнаружили следующее, что может быть связано:

[debug] [2020-10-22T22:06:39.394Z] 15:06:39.394 [FirebaseWorkerPool-1-2] WARN com.firebase.core.namespace.NamespaceActorSystem - Request for ns: likemindedly-stage has incorrect domain. Current domain: 0.0.0.0, expected domain: firebaseio-staging.com
 {"metadata":{"emulator":{"name":"database"},"message":"15:06:39.394 [FirebaseWorkerPool-1-2] WARN com.firebase.core.namespace.NamespaceActorSystem - Request for ns: likemindedly-stage has incorrect domain. Current domain: 0.0.0.0, expected domain: firebaseio-staging.com\n"}}
[debug] [2020-10-22T22:06:39.448Z] <<< HTTP RESPONSE 404 {"content-length":"231","content-type":"application/json; charset=utf-8","access-control-allow-origin":"*","cache-control":"no-cache"}
[debug] [2020-10-22T22:06:39.448Z] <<< HTTP RESPONSE BODY {
  "correctUrl" : "https://likemindedly-stage.firebaseio-staging.com",
  "error" : "Namespace likemindedly-stage lives in a different region. Please change your database URL to https://likemindedly-stage.firebaseio-staging.com"
}

Кажется, что мы жалуемся, что мы указываем на локальные эмуляторы в нашей конфигурации, хотя непонятно, почему это может быть проблемой?

2
melchoir55 23 Окт 2020 в 01:12

2 ответа

Лучший ответ

Я также столкнулся с этой проблемой всего несколько часов назад. Это позволило мне запустить эмуляторы как обычно, когда я удалил хосты из своего firebase.json, но я не понял, что именно вызывает ошибку или как правильно установить хосты вне файла json.

3
RSB 23 Окт 2020 в 22:16

Другой способ решить эту проблему - добавить новый эмулятор аутентификации firebase в ваш набор эмуляторов.

0
melchoir55 11 Ноя 2020 в 20:48