У меня есть сервер Ubuntu на вычислительном движке Google, который я разрешил использовать ufw, но забыл разрешить порт 22 для соединений ssh, и теперь я не могу получить к нему доступ

  • Есть идеи, как я могу это изменить?

Я также пытался подключиться с помощью последовательной консоли Google, но не могу вспомнить имя пользователя и пароль своего экземпляра.

  • Где они установлены?
0
Aya Mohamed 14 Мар 2018 в 14:24

2 ответа

Лучший ответ

Я бы посоветовал вам запустить сценарий запуска и установить имя пользователя и пароль для доступа через последовательную консоль или напрямую, чтобы изменить ufw, записав в скрипт команды, которые вы бы использовали.

Обратите внимание, что сценарий запуска запускается от имени пользователя root.

1
GalloCedrone 14 Мар 2018 в 11:33

Этот ответ от Server Fault решил проблему для меня. Используйте любой из 2 методов. Я использовал первый:

  1. Способ 1. Добавьте сценарий запуска на страницу настроек экземпляра, чтобы отключить ufw.

    #! /bin/bash
    /usr/sbin/ufw disable
    
  2. Метод 2 : подключите загрузочный диск к другому экземпляру и измените файл /etc/ufw/ufw.conf

См. Ссылку для получения подробных инструкций

1
Musili 7 Фев 2019 в 12:48