Я пытаюсь установить djangular-serve в свой проект, но не знаю, какую версию setuptools_Scm он запрашивает.

  Using cached djangular-serve-2.1.0.tar.gz (34 kB)
  Installing build dependencies ... error
  error: subprocess-exited-with-error

  × pip subprocess to install build dependencies did not run successfully.
  │ exit code: 1
  ╰─> [4 lines of output]
      Collecting setuptools>=49.6.0
        Using cached setuptools-65.6.3-py3-none-any.whl (1.2 MB)
      ERROR: Could not find a version that satisfies the requirement setuptools_scm<3,>=4.1.2 (from versions: 1.0.0, 1.1.0, 1.2.0, 1.3.0, 1.4.0, 1.4.1, 1.5.0, 1.5.2, 1.5.3, 1.5.4, 1.5.5, 1.6.0, 1.7.0, 1.8.0, 1.9.0, 1.10.0, 1.10.1, 1.11.0, 1.11.1, 1.13.0, 1.13.1, 1.14.0rc1, 1.14.0, 1.15.0rc1, 1.15.0, 1.15.1rc1, 1.15.4, 1.15.5, 1.15.6, 1.15.7, 1.16.0, 1.16.1, 1.16.2, 1.17.0, 2.0.0, 2.1.0, 3.0.0, 3.0.1, 3.0.2, 3.0.4, 3.0.5, 3.0.6, 3.1.0, 3.2.0, 3.3.1, 3.3.2, 3.3.3, 3.4.0, 3.4.1, 3.4.2, 3.4.3, 3.5.0, 4.0.0, 4.1.0, 4.1.1, 4.1.2, 5.0.0, 5.0.1, 5.0.2, 6.0.0, 6.0.1, 6.1.0.dev0, 6.1.0, 6.1.1, 6.2.0, 6.3.0, 6.3.1, 6.3.2, 6.4.0, 6.4.1, 6.4.2, 7.0.0, 7.0.1, 7.0.2, 7.0.3, 7.0.4, 7.0.5)
      ERROR: No matching distribution found for setuptools_scm<3,>=4.1.2
      [end of output]

  note: This error originates from a subprocess, and is likely not a problem with pip.
error: subprocess-exited-with-error

Я запутался, как версия может быть больше 4.1.2 но меньше 3? Нужно ли исправлять настройку? Как мне загрузить пакет и сделать это, если мне нужно это исправить?

-1
tayoung 25 Ноя 2022 в 21:18

1 ответ

Это ошибка в djangular-serve в pyproject.toml. Пожалуйста, сообщите об ошибке. Тот факт, что никто не сообщил об ошибке в течение двух лет, говорит о том, что пакет не очень популярен среди пользователей.

0
phd 25 Ноя 2022 в 21:32