У меня IBM mobilefirst 7.1. Я хочу знать, как я могу проверить версию Cordova, которая используется в mobilefirst. Я видел что-то под названием var PLATFORM_VERSION_BUILD_LABEL = '3.6.4' в cordova.js внутри проекта. Я предполагаю, что это версия кордовы, которая используется в мобильном телефоне. На своей машине я дал cordova -v, он сказал 5.0.0. У меня есть зависимость от интеграции push-уведомлений ibm bluemix с мобильным первым гибридным приложением. Версия кордовы должна быть ниже 4.3 (push без инициализации при попытке создать гибридное приложение для Android).

Вот мои вопросы:
Как я могу увидеть версию кордовы, которая находится в рабочем свете? Если мне нужно перейти на более раннюю версию, что мне делать? Понижение уровня кордовы снаружи повлияет на что-нибудь в мобильном телефоне.

1
Sharan Ainapurapu 28 Окт 2015 в 10:22

2 ответа

Лучший ответ

MobileFirst Platform Foundation включает в себя Кордову. Вы не можете заменить его каким-либо образом (обновить или понизить).

MobileFirst Platform Foundation 7.1 использует Cordova 3.6.4.

Эта версия 5.0, которую вы видите, скорее всего, исходит от локальной установки Cordova на вашей рабочей станции и не имеет отношения к MobileFirst.

2
Idan Adar 28 Окт 2015 в 07:33

Вы всегда можете проверить папку wl / your_project_name / apps / project_name / iphone / native / CordovaLib /, и там будет файл с именем VERSION. Он покажет вам точную версию. Вижу версию 3.7.0.

Примечание: этот файл будет отображаться в собственной папке после создания приложения.

1
Siva 6 Ноя 2015 в 16:09