Я пытаюсь создать приложение для Windows с недавно установленной Visual Studio.

Когда я начинаю новый проект, я получаю это сообщение.

Требуется обновление Visual Studio

Для одного или нескольких проектов требуется SDK платформы (UAP, версия: 10.0.0.0), который либо не установлен, либо включен в будущие обновления Visual Studio. Установите SDK платформы, чтобы открыть эти проекты.

Когда я нажимаю кнопку «Установить», я попадаю на домашнюю страницу Microsoft без какой-либо ссылки для загрузки, что отчасти бесполезно!

Но, как видно на скриншоте ниже, у меня установлена ​​последняя версия:

enter image description here

16
Waza_Be 16 Окт 2015 в 15:00

3 ответа

Лучший ответ

Пришлось сменить визуальную студию в программе и настройках. Затем я изменил его -> удалив все параметры универсального приложения Windows.

enter image description here

Тогда

Затем

Затем я снова изменил его и снова добавил параметры универсального приложения Windows. Это произошло после попытки загрузить и установить универсальный SDK для Windows как отдельную версию. Что не сработало

9
22 Окт 2015 в 07:32
  1. Проверьте целевую версию в вашем рабочем последнем рабочем проекте:

Щелкните правой кнопкой мыши свой проект в Visual Studio -> Свойства -> Приложение -> Таргетинг -> Целевая версия (в моем случае сборка 14295)

  1. Изменить целевую версию в неудачном проекте:

Щелкните правой кнопкой мыши неудачный проект в Visual Studio -> Изменить -> Изменить целевую версию -> снова щелкните правой кнопкой мыши проект -> Перезагрузить

Вот и все, ребята!

2
Jet Chopper 5 Июл 2016 в 09:46

Для меня это просто вопрос редактирования файла проекта (щелкните проект правой кнопкой мыши и выберите Изменить [название проекта] ) и измените следующую строку:

<TargetPlatformVersion>10.0.10586.0</TargetPlatformVersion>

К

<TargetPlatformVersion>10.0.14393.0</TargetPlatformVersion>

Нажав команду Перезагрузить проект после этого изменения, VS открыл его для меня.

Стоит отметить, что я обновил свой VS2015 обновлением 3, которое, вероятно, установило для меня новейшую версию SDK.

5
dotNET 17 Сен 2016 в 19:37