Можете ли вы предоставить подробную информацию о сообществе Moodle с открытым исходным кодом. Я погуглил, но я не получил информацию полностью. Я загрузил zip-папку при открытии на моем локальном хосте, это дает ошибку.

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in D:\xampp\htdocs\moodle\index.php on line 218

Я хочу, как установить и как проверить это на localhost, пожалуйста, помогите мне

1
user5260349 28 Окт 2015 в 13:58

3 ответа

Лучший ответ

Попробуйте эту ссылку для загрузки moodle и последней версии

https://download.moodle.org/releases/latest/

Это может быть полезно для вас

0
naresh 28 Окт 2015 в 11:06

Указанная вами ошибка появляется при попытке установить Moodle на очень-очень старую версию PHP - она ​​не знает, как работать с пространствами имен, и дает сбой даже до выполнения проверки среды.

Пожалуйста, проверьте требования для устанавливаемой версии Moodle и обновите свой PHP.

Если хотите, вы можете проголосовать за проблему, когда люди жалуются на запутанное сообщение об ошибке: https://tracker.moodle.org/browse/MDL-44276

0
Marina 20 Ноя 2015 в 03:23

Пошаговая инструкция по установке

https://docs.moodle.org/29/en/Installing_Moodle

1
Russell England 28 Окт 2015 в 15:27