Я загружаю свой файл IPA в магазин приложений, и он выдает мне ошибку ниже:

ОШИБКА ITMS-90062: «Этот пакет недействителен. Значение ключа CFBundleShortVersionString [3.0.0] в файле Info.plist должно содержать более высокую версию, чем у ранее утвержденной версии [3.0.1].»

Ниже мой конфиг для IOS:

 "ios": {
      "bundleIdentifier": "com.test.test.test",
      "buildNumber": "5",
      "icon": "./assets/images/test.png",
      "config": {
        "googleSignIn": {
          "reservedClientId": ""
        }
      },
      "infoPlist": {
        "NSLocationWhenInUseUsageDescription": "Your current location will be displayed on the map and used for directions, nearby search results, and estimated travel times.",
        "CFBundleShortVersionString":"3.0.3",
        "CFBundleIdentifier": "com.test.test.test"
      }
    }
0
Akshay Seth 21 Авг 2018 в 09:43

4 ответа

Лучший ответ

Похоже, что магазин приложений выбирал версию из моего файла package.json с ключом версии. Я обновил его до 4.0.0, и он работал успешно. Я полагаю, что возникли некоторые проблемы с экспозицией.

0
Akshay Seth 24 Авг 2018 в 05:58

Если версия приложения [3.0.3] уже утверждена, вы увеличите номер версии [3.0.4] . Если вы увеличите номер сборки , вы получите ту же ошибку .

2
Mohammed Ashfaq 21 Авг 2018 в 07:33

Вы должны отклонить сборку в iTunesConnect и отправить новую сборку с большим номером сборки

1
Vadim Komisarchik 14 Фев 2020 в 17:13

Попробуйте изменить buildNumber и сделать его выше 5.

0
iMark 21 Авг 2018 в 06:58
51943005