У меня простая опечатка? Нужно ли мне еще что-нибудь устанавливать? Я получаю следующее сообщение об ошибке:

«Модуль не найден: не удается разрешить '@ stripe / react-stripe.js'»

У меня также установлен npm: @ stripe / react-stripe-js @ stripe / stripe-js

Благодарим за любую помощь в выяснении этого вопроса!

Ниже приведены скриншоты для справки: введите здесь описание изображения

enter image description here

0
Alex 13 Фев 2021 в 12:08

1 ответ

Лучший ответ
import ... from '@stripe/react-stripe-js'

Вы неправильно импортируете его. @stripe/react-stripe.js неверно. Просто замените . на -, тогда он должен работать.

Как вы можете видеть в его документе. Вам необходимо импортировать его компонент из @stripe/react-stripe-js

stripe-js правильный оператор импорта

1
sadrzadehsina 13 Фев 2021 в 09:20