Я использую Selenium в Java, чтобы сделать приложение. Я продолжаю получать эту ошибку, и я искал в Интернете, чтобы выяснить, что не так, и я не могу ничего найти. Пожалуйста помоги.

Вот мой build.gradle:

    android {
    compileSdkVersion 26
    defaultConfig {
        applicationId "luke.luke.seleniumtest"
        minSdkVersion 15
        targetSdkVersion 26
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}



dependencies {
    implementation fileTree(include: ['*.jar'], dir: 'libs')
    implementation 'com.android.support:appcompat-v7:26.1.0'
    implementation 'com.android.support.constraint:constraint-layout:1.0.2'
    androidTestImplementation 'com.android.support.test:runner:1.0.1'
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.1'
    implementation files('libs/byte-buddy-1.7.9.jar')
    implementation files('libs/client-combined-3.9.1.jar')
    implementation files('libs/commons-codec-1.10.jar')
    implementation files('libs/commons-exec-1.3.jar')
    implementation files('libs/commons-logging-1.2.jar')
    implementation files('libs/gson-2.8.2.jar')
    implementation files('libs/guava-23.6-jre.jar')
    implementation files('libs/httpclient-4.5.3.jar')
    implementation files('libs/httpcore-4.4.6.jar')
    implementation files('libs/okhttp-3.9.1.jar')
    implementation files('libs/okio-1.13.0.jar')
}
9
LUKER 24 Фев 2018 в 05:54

3 ответа

Лучший ответ

Сначала попробуйте добавить эту строку: исключите «META-INF / DEPENDENCIES», затем запустите «app»

android {
    packagingOptions {
        exclude 'META-INF/DEPENDENCIES'
    }
}

Если ошибка продолжает возникать: «META-INF / INDEX.LIST», продолжайте добавлять исключение «META-INF / INDEX.LIST»:

android {
    packagingOptions {
        exclude 'META-INF/DEPENDENCIES'
        exclude 'META-INF/INDEX.LIST'
    }
}

Удачи для меня!

10
TedVN 1 Ноя 2018 в 09:42

Попробуйте добавить комплектацию

android {
    packagingOptions {
        exclude 'META-INF/DEPENDENCIES'
    }
}
2
sanemars 24 Фев 2018 в 02:57

Простое решение вместо того, чтобы исключить это просто сделать

android {
    packagingOptions {
        pickFirst  'META-INF/*'
    }
}
12
Brent 4 Мар 2020 в 17:10