Я только что установил Visual Studio Code вместе с Java Extension Pack. Однако, когда я открыл свой первый файл и начал печатать, набираемый текст появляется через некоторое время - он достигает даже одной секунды.
У меня есть догадка, что это может быть связано с количеством процессов, идущих за редактором, таких как проверка синтаксиса в режиме реального времени, автозаполнение, подсказки кода и так далее. Возможно, ноутбук, на котором я работаю, просто не справится с этим. Вот параметры моей нынешней машины:
Процессор: Intel (R) Caleron (R) CPU N3350 (1,10 ГГц)
Оперативная память: 4 ГБ

У меня есть еще одна догадка, что это может быть связано с процессором.

Итак, есть ли способы отключить эти средства, такие как проверка ошибок в реальном времени? Если нет, то какие еще IDE для Java вы бы порекомендовали? (Кроме Затмения)

7
Aemilius 24 Фев 2018 в 13:27

3 ответа

Лучший ответ

У меня была та же проблема с использованием кода Visual Studio при использовании Android Studio вместе с Android Simulator в фоновом режиме , и я запустил 8 ГБ ОЗУ и ЦП 3,2 ГГц но когда я вернулся в Notepad ++ (я знаю, что это самоубийство), чтобы проверить, является ли это моей проблемой или из-за IDE, я набрал в режиме реального времени.

Это связано с вашим процессором, так как код Visual Studio не рекомендуется для «медленных» процессоров. Лично мне это нравится, хотя IDE в Vim может подойти вам лучше.

Вот ссылка, которая может дать еще несколько советов: https://github.com/Microsoft/vscode/issues/38409

3
Efthimis_28 24 Фев 2018 в 11:13

Самым простым решением, которое я нашел, было загрузить и установить инсайдеры кода Visual Studio. Он почти идентичен, за исключением того, что он меньше лагает. Установка этого также очистит любые расширения или предпочтения, которые вы включили, которые могут вызвать задержку:

https://code.visualstudio.com/insiders/

Вам также может потребоваться запустить его из командной строки с флагом --disable-gpu

code-insiders --disable-gpu

Или

/Applications/Visual\ Studio\ Code\ -\ Insiders.app/Contents/MacOS/Electron --disable-gpu

В зависимости от вашей ОС

0
emery 12 Май 2020 в 21:08

То же самое для меня, я часто позволяю компьютеру спать вместо того, чтобы выключать и убивать все процессы, поэтому для меня было нормальным, что VS был открыт в течение нескольких дней, было решение закрыть Visual Studio и снова открыть его.

0
Tsvetomir Iliev 4 Мар 2019 в 05:47