Сборка Android продолжает вылетать из-за зависимости firebase_ml_vision.

Ниже представлен вывод консоли отладки при запуске сборки для Android.

> In project 'app' a resolved Google Play services library dependency depends on another at an exact version (e.g. "[19.0.
  2]", but isn't being resolved to that version. Behavior exhibited by the library will be unknown.
  
  Dependency failing: com.google.android.gms:play-services-vision:20.0.0 -> com.google.android.gms:play-services-vision-co
  mmon@[19.0.2], but play-services-vision-common version was 19.1.0.
  
  The following dependencies are project dependencies that are direct or have transitive dependencies that lead to the artifact with the issue.
 -- Project 'app' depends onto com.google.firebase:firebase-ml-vision@{strictly 24.1.0}
  -- Project 'app' depends on project 'firebase_ml_vision' which depends onto com.google.firebase:firebase-ml-vision@20.0.
  0
  -- Project 'app' depends onto com.google.android.gms:play-services-vision-common@{strictly 19.1.0}
  -- Project 'app' depends onto com.google.firebase:firebase-bom@{strictly 25.12.0}
  -- Project 'app' depends onto com.google.firebase:firebase-bom@25.12.0
  -- Project 'app' depends onto com.google.android.gms:play-services-vision-image-label@{strictly 18.0.4}
  -- Project 'app' depends onto com.google.android.gms:play-services-vision@{strictly 20.0.0}
0
James 10 Окт 2020 в 15:32

1 ответ

Лучший ответ

Зайдите в свой файл android/app/build.gradle.

Внизу у вас должен быть dependencies object. Удалите конкретную версию из firebase-bom ниже.

Перед:

dependencies {
    implementation platform('com.google.firebase:firebase-bom:25.12.0')
    ...
}

После:

dependencies {
    implementation platform('com.google.firebase:firebase-bom')
    ...
}
1
James 10 Окт 2020 в 12:32