Я только что впервые создал свое приложение React Native, и после создания .ipa и установки его на свое устройство для тестирования я получаю предупреждение с заголовком "MyApp - iOS" Needs To Be Updated и телом This app needs to be updated by the developer to work on this version of iOS .

В моем проекте ReactNative я установил цель iOS на 10.0, а версию iOS на телефоне - 14.2, поэтому я не понимаю, почему это не работает. Я изо всех сил пытался найти какие-либо полезные ресурсы в поисковой системе.

0
badsyntax 19 Мар 2021 в 18:05

1 ответ

Лучший ответ

Я сделал ошибку в моих «Исключенных архитектурах». Я установил для всех исключенных архитектур значение «arm64», тогда как мне следовало исключить только arm64 для симулятора.

Вот обновленные настройки сборки, которые работают:

enter image description here

Это код различия:

-                               EXCLUDED_ARCHS = arm64;
+                               "EXCLUDED_ARCHS[sdk=iphonesimulator*]" = arm64;

Надеюсь, это поможет другим.

0
badsyntax 19 Мар 2021 в 15:05