Я новичок в VS Code, начиная с ST3 и TextMate до этого. Немного сбит с толку, почему HTML не определяется автоматически и не предлагается в качестве выбора языка после нажатия на нижний правый индикатор языка?

Screenshot after selecting "Configure File Association for '.html'..."

Я пытался явно добавить "files.associations": {"*.html": "html"} в настройки пользователя, но безрезультатно.

Запуск VSCode v1.15.1 на macOS v10.12.6.

18
nootrope 5 Сен 2017 в 00:58

6 ответов

Лучший ответ

Включить следующую строку настройки emmet.includeLanguages": {"django-html": "html"} в Настройки VSCode.json:

{
"python.jediEnabled": false,
"files.autoSave": "afterDelay",
"editor.suggestSelection": "first",
"vsintellicode.modify.editor.suggestSelection": 
"automaticallyOverrodeDefaultValue",
"editor.minimap.enabled": true,
"workbench.colorTheme": "Monokai",
"editor.largeFileOptimizations": false,
"html.format.indentInnerHtml": true,
"html.format.indentHandlebars": true,
"emmet.includeLanguages": {"django-html": "html"},
"[django-html]": {

},
"files.associations": {
    "*.html": "html"
}

}

Это делает исправление для меня в версии 1.33.1

19
onlyphantom 12 Ноя 2019 в 04:32

Решено! Я начал удалять расширения и обнаружил, что виноват Django Template 1.2.0 (bibhasdn.django-html). Как только я отключил его, опция HTML вернулась в меню «Языковые ассоциации». Шляп на @ifconfig, подтверждающий, что я должен ожидать его появления.

20
nootrope 5 Сен 2017 в 04:35

Пакет расширения Python, включающий пакеты DJANGO, позволил VSCOde видеть все HTML как шаблоны Django и устанавливать комментарии как {% comment%} вместо <!-- -->

Удаление это решило проблему.

6
Tzvi Gregory Kaidanov 11 Июл 2018 в 06:52

image for the same

1) Нажмите «Выбор языка» в нижней правой панели инструментов.

2) Выберите «Настроить сопоставление файлов для .html» из выпадающего списка.

3) Выберите html из выпадающего списка.

Это приведет к удалению html-файла, помеченного как Django-html каждый раз, когда вы создаете html-документ.

1
Ardent Coder 13 Май 2020 в 22:01

Эти настройки работали у меня в vscode settings.json

"files.associations": {
    "**/templates/*.html": "django-html",
    "**/templates/*": "django-txt",
    "**/requirements{/**,*}.{txt,in}": "pip-requirements",
    "*.html": "html"
  },
  "emmet.includeLanguages": { "django-html": "html" }
0
Ibrahim Noor 15 Авг 2020 в 10:59

Я думаю, что самый простой способ - это проверить. В правом нижнем углу кода вы можете увидеть нижний колонтитул, как показано на рисунке ниже.

Image of relevant part of VS Code IDE

Итак, нажмите там Django HTML . Затем можно увидеть всплывающее окно с вводом. Введите HTML в качестве ввода и выберите HTML . Задача решена.

1
colidyre 29 Фев 2020 в 11:22