Я пытаюсь выучить Python, следуя книге «Ускоренный курс Python», но я застрял, потому что в книге не используется IDE, которую я использую, PyCharm.

Проблема, с которой я сталкиваюсь, заключается в том, что когда я пытаюсь импортировать pygame, он говорит module not found.

Я успешно установил pygame с помощью этой команды:

python -m pip install --user pygame

скриншот командной строки

Я получаю сообщение "успешно установлена Pygame"

Но я все еще не могу импортировать его. Я заметил, что PyCharm использует интерпретатор из этого места: \HelloWorld\venv\Scripts\python.exe

Который находится внутри папки проекта.

Мой питон установлен в:

\AppData\Local\Programs\Python\Python36-32\python.exe

Как я могу предоставить виртуальной среде PyCharm доступ к pygame?

Спасибо!

2
Darren 26 Фев 2018 в 08:24

4 ответа

Лучший ответ

Вам нужно изменить интерпретатор проекта pycharm

Попал в File -> Setting -> your_project -> интерпретатор проекта

И затем выберите Venv, где вы установили нужную библиотеку.

enter image description here

1
om tripathi 26 Фев 2018 в 05:32

Спасибо за все ваши предложения. Ответы jackotonye и om tripathi верны. Я просто предпочитаю jackotonye, но вместо 'add local' я устанавливаю модуль pygame

Вот что я сделал на PyCharm:

File -> Settings -> Project: HelloWorld -> Project Interpreter -> '+' (plus sign)

Это позволит вам установить пакеты / модуль в вашем venv.

Но я думаю, вам придется делать это для каждого проекта, который вы создадите, если вы не выбрали «Настройки по умолчанию» вместо «Настройки» в приведенной выше инструкции.

PS: ответ om tripathi тоже работает, меняя переводчика на мой родной python вместо python venv.

Спасибо!

0
Darren 27 Фев 2018 в 03:11
PyCharm -> Prefrences -> Project -> Project Interpreter -> Add Local
1
jackotonye 26 Фев 2018 в 05:33

Попробуйте установить пакет из интерпретатора проекта, указанного в pycharm

1
Harsh Mehta 26 Фев 2018 в 05:33