Я добавил следующие библиотеки в мой Android. После этого я получаю сообщение об ошибке.

< Сильный > Ошибка:

Error:Execution failed for task ':app:javaPreCompileDebug'.
> Annotation processors must be explicitly declared now.  The following dependencies on the compile classpath are found to contain annotation processor.  Please add them to the annotationProcessor configuration.
    - compiler-4.6.1.jar (compiler-4.6.1.jar)   Alternatively, set android.defaultConfig.javaCompileOptions.annotationProcessorOptions.includeCompileClasspath
= true to continue with previous behavior.  Note that this option is deprecated and will be removed in the future.   See https://developer.android.com/r/tools/annotation-processor-error-message.html for more details.

< Сильный > Gradle :

apply plugin: 'com.android.application'

android {
    compileSdkVersion 26
    defaultConfig {
        applicationId "com.example.usamaakmal.bookswap"
        minSdkVersion 21
        targetSdkVersion 26
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    implementation fileTree(include: ['*.jar'], dir: 'libs')
    implementation 'com.android.support:appcompat-v7:26.1.0'
    implementation 'com.android.support.constraint:constraint-layout:1.0.2'
    implementation 'com.android.support:support-v4:26.1.0'
    implementation 'com.android.support:design:26.1.0'
    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'com.android.support.test:runner:1.0.1'
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.1'
    compile 'com.squareup.retrofit2:retrofit:2.3.0'
    compile 'com.squareup.retrofit2:converter-gson:2.3.0'
    compile 'com.google.code.gson:gson:2.7'
    compile 'com.jaredrummler:material-spinner:1.2.4'
    compile 'com.mikhaellopez:circularimageview:3.0.2'
    implementation 'com.android.support:cardview-v7:26.1.0'
}
2
Usama Akmal 3 Мар 2018 в 07:13

5 ответов

Лучший ответ

В библиотеке возникла какая-то проблема, поэтому я решил Пикассо против этого.

-1
Nikunj 7 Мар 2018 в 07:01

Просто прочитайте инструкции по установке и следуйте им (используйте implementation вместо compile, если ваша версия Gradle позволяет это): http://bumptech.github.io/glide/doc/download- setup.html # Gradle

Также убедитесь, что вы удалили все локальные копии файлов Glide .jar в папке libs. У меня ощущение, что https://stackoverflow.com/a/49080598/253468 не работает, потому что вы все еще используете оригинальный проблемный способ потребления библиотеки; в целом для Android вам не нужно использовать папку libs, экосистема достаточно развита, чтобы иметь опубликованные библиотеки jcenter / mavenCentral.

0
TWiStErRob 11 Май 2018 в 21:21

Нет необходимости использовать glide в качестве библиотеки jar.

Просто используйте его зависимость ...

В файле project-> build.gradle:

Добавьте этот код.

repositories {
  mavenCentral()
  google()
}

В файле приложения build.gradle: добавьте этот код.

dependencies {
  implementation 'com.github.bumptech.glide:glide:4.6.1'
  annotationProcessor 'com.github.bumptech.glide:compiler:4.6.1'
}

Надеюсь, это поможет вам.

1
Milan Hirpara 3 Мар 2018 в 04:19

Я столкнулся с этим при попытке использовать скольжение. Если вы используете Kotlin. Вы должны добавить это

dependencies {
  kapt 'com.github.bumptech.glide:compiler:4.9.0'
}

Проверьте инструкции здесь http://bumptech.github.io/glide/ док / скачать - setup.html # Gradle

1
Frank Teng 11 Ноя 2019 в 22:07

В файле приложения build.gradle: Добавьте этот код:

android {
    ...
    defaultConfig {
       ...
       javaCompileOptions { annotationProcessorOptions { includeCompileClasspath = true } }
    }
}
-1
Stephen Rauch 23 Май 2018 в 01:42