Я получаю эту ошибку:

enter image description here

Версии sdk My Pods File следующие:

enter image description here

Очевидно, что модули Firebase больше 5.0. Люди упоминают, что эта проблема была только в модулях Firebase 4.0, но я все еще сталкиваюсь с этим.

Для параметра Build active architetures only установлено значение No.

Я удалил устаревший модуль Google, и теперь мой podfile.lock выглядит так. Но проблема все еще существует.

enter image description here

Дайте мне знать, если мне нужно добавить что-нибудь еще.

1
Shivam Tripathi 9 Ноя 2018 в 14:10

1 ответ

Лучший ответ

В Podfile удалите спецификатор версии Firebase.

В качестве альтернативы можно изменить спецификатор версии Firebase, чтобы заблокировать его до второстепенных выпусков с помощью ~> 5.0 вместо текущей блокировки для исправления обновлений с помощью ~> 5.0.0.

Похоже, что не все компоненты Firebase должным образом обновили свои спецификаторы зависимости от версии с момента выпуска Firebase 5.0.1. Похоже, ваш Podfile привязан к выпуску патча 5.0.x, который раскрывает вам проблему.

Если проблема не исчезла, поделитесь файлом Podfile.

1
Paul Beusterien 11 Ноя 2018 в 17:59