Я получаю следующую ошибку после обновления моего проекта до последних зависимостей

Не нашел класс "com.google.android.gms.common.util.zzq" по пути: DexPathList [[zip-файл "/system/framework/org.apache.http.legacy.boot.jar", zip-файл " /data/app/com.example.example-jBf5YcFyN-t4Cm8erTCBwQ==/base.apk" ],nativeLibraryDirectories=[/data/app/com.example.example-jBf5YcFyN-t4Cm8erTCBwQ== / system /x86 / system /x86 lib]] "

apply plugin: 'com.android.application'

android {
    compileSdkVersion 27
    defaultConfig {
        applicationId "com.example.example"
        minSdkVersion 21
        targetSdkVersion 27
        versionCode 1
        versionName "1.0"
        // Enabling multidex support.
        multiDexEnabled true

        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled true
            shrinkResources true
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
    dataBinding {
        enabled true
    }
//    buildToolsVersion '28.0.3'

    compileOptions {
        sourceCompatibility JavaVersion.VERSION_1_8
        targetCompatibility JavaVersion.VERSION_1_8
    }
}

dependencies {
    implementation fileTree(include: ['*.jar'], dir: 'libs')
    implementation 'com.android.support:appcompat-v7:27.1.1'
    implementation 'com.android.support:animated-vector-drawable:27.1.1'
    implementation 'com.android.support:customtabs:27.1.1'
    implementation 'com.android.support:support-v4:27.1.1'
    implementation 'com.android.support:design:27.1.1'
    implementation 'com.android.support.constraint:constraint-layout:1.1.3'
    implementation 'com.android.support:cardview-v7:27.1.1'

    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'com.android.support.test:runner:1.0.2'
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'

    implementation 'com.android.support:multidex:1.0.3'
    implementation 'com.android.volley:volley:1.1.0'
    implementation 'com.google.code.gson:gson:2.8.5'
    implementation 'org.jsoup:jsoup:1.10.3'

    implementation 'com.google.android.gms:play-services-maps:16.0.0'
    implementation 'com.google.android.gms:play-services-location:16.0.0'
    implementation 'com.google.android.gms:play-services-places:16.0.0'

    implementation 'com.google.firebase:firebase-messaging:17.3.4'
    implementation 'com.google.firebase:firebase-core:16.0.5'
    implementation 'com.crashlytics.sdk.android:crashlytics:2.9.6'

    implementation 'com.facebook.android:facebook-android-sdk:4.32.0'
    implementation 'com.intuit.sdp:sdp-android:1.0.5'
    /*map place autosuggest*/
    //for calendar class
    implementation 'joda-time:joda-time:2.9.9'
    implementation 'de.hdodenhof:circleimageview:2.2.0'
    //QB dependecies
    implementation 'com.quickblox:quickblox-android-sdk-core:3.8.1'
    implementation('com.quickblox:quickblox-android-sdk-chat:3.8.0') {
        transitive = true
    }
    implementation 'com.quickblox:chat-message-adapter:2.0'
    implementation 'com.quickblox:quickblox-android-sdk-content:3.8.0'
    implementation 'com.timehop.stickyheadersrecyclerview:library:0.4.2@aar'
    implementation 'com.github.orangegangsters:swipy:1.2.3@aar'
    implementation project(':sample-core')

//    implementation 'com.jwang123.flagkit:flagkit:1.0'
}
apply plugin: 'com.google.gms.google-services'
apply plugin: 'io.fabric'

//GoogleServicesPlugin.config.disableVersionCheck = true

Может ли кто-нибудь посоветовать мне, как решить эту проблему. Я искал stackoverflow за последние два дня для решения этой проблемы. Пожалуйста помоги.

0
divaPrajapati09 13 Ноя 2018 в 16:37

1 ответ

Лучший ответ
Ensure that your top-level build.gradle contains a reference to the google() repo or to maven { url "https://maven.google.com" }.

Удалите это из файла build.gradle и снова синхронизируйте

 apply plugin: 'com.google.gms.google-services'
4
Sultan Mahmud 14 Ноя 2018 в 05:02