Ниже содержание:

interface Vlan10
  ip address 10.17.8.17/30
  ip ospf message-digest-key 1 md5 3 xsdssdsdjhsd
  ip router ospf 14 area 0.0.0.0
  no shutdown
interface Vlan140
  vrf member Automation
  ip address 10.75.54.14/30
  ip router eigrp 1
  no shutdown
interface Vlan150
  vrf member Automation
  ip address 10.15.24.29/30
  ip router eigrp 1
  no shutdown
interface Vlan24
  ip address 10.17.54.50/30
  ip router eigrp 10
  no shutdown
interface Vlan101
  ip address 10.11.10.2/24
  ip ospf cost 1000
  ip router ospf 14 area 0.0.0.1
  no shutdown
interface Vlan1221
  ip address 10.41.12.4/30
  ip ospf cost 10
  ip router ospf 1 area 0.0.0.0
  no shutdown
interface Vlan122
  ip address 10.14.2.53/30
  ip ospf cost 9
  ip router ospf 1 area 0.0.0.0
  no shutdown
interface Vlan1258
  vrf member Automation
  ip address 10.11.1.23/30
  ip router eigrp 1
  no shutdown
interface port-channel16
  switchport
  switchport mode trunk
  switchport trunk allowed vlan 10,15,121

Нужна помощь в захвате ip router eigrp и ip address, которые являются дочерним элементом и именем интерфейса (vlan, ethernet) и т. Д. ... в конце повторите этот процесс для всех интерфейсов, содержащих все три.

Ожидаемые группы - это имя интерфейса, IP-адрес, номер eigrp для каждого интерфейса и повторяются для всех интерфейсов.

Просто для добавления нужно только захватить интерфейсы, у которых есть eigrp.

Пробовал, но не сработало -> ^ interface (\ S +)? (?: \ S +)? (? :( ip-адрес) (\ S +))? (? :( ?: ip router eigrp) (\ S +) )

-4
netauto 3 Дек 2018 в 07:26

1 ответ

Лучший ответ

Выяснили способ фильтрации на основе маршрутизатора eigrp или ospf с ретроспективным просмотром, а затем сквозной цикл с использованием ansible.

^ интерфейс (\ S +) (?: \ n \ s {2}. ) (? <= eigrp)

0
netauto 4 Дек 2018 в 02:19