Я пробовал создать приложение для браузера с

ionic cordova build browser --prod

Но это вызывает эту ошибку: RegExp для поиска DeepLinkConfigToken не вернул действительные данные

Я использую Angular 4.4.6. Я читал, что понижение версии Angular до 4.1 решает проблему. Но я попробовал, и ничего не вышло.

Заранее спасибо.

Это мои зависимости:

    "dependencies": {
        "@angular/animations": "~4.4.6",
        "@angular/common": "~4.4.6",
        "@angular/compiler": "~4.4.6",
        "@angular/compiler-cli": "~4.4.6",
        "@angular/core": "~4.4.6",
        "@angular/forms": "~4.4.6",
        "@angular/http": "~4.4.6",
        "@angular/platform-browser": "~4.4.6",
        "@angular/platform-browser-dynamic": "~4.4.6",
        "@ionic-native/camera": "~4.7.0",
        "@ionic-native/core": "~4.7.0",
        "@ionic-native/facebook": "~4.5.3",
        "@ionic-native/file": "~4.7.0",
        "@ionic-native/file-transfer": "~4.7.0",
        "@ionic-native/geolocation": "~4.7.0",
        "@ionic-native/google-plus": "~4.7.0",
        "@ionic-native/splash-screen": "~4.7.0",
        "@ionic-native/status-bar": "~4.7.0",
        "@ionic/storage": "~2.1.3",
        "@ngx-translate/core": "~7.2.2",
        "@ngx-translate/http-loader": "~2.0.1",
        "cordova-android": "~6.4.0",
        "cordova-browser": "~4.1.0",
        "cordova-plugin-camera": "~4.0.2",
        "cordova-plugin-console": "~1.1.0",
        "cordova-plugin-device": "~1.1.7",
        "cordova-plugin-facebook4": "~1.9.1",
        "cordova-plugin-file": "~6.0.1",
        "cordova-plugin-file-transfer": "~1.7.1",
        "cordova-plugin-geolocation": "~4.0.1",
        "cordova-plugin-googleplus": "~5.2.3",
        "cordova-plugin-splashscreen": "~4.1.0",
        "cordova-plugin-statusbar": "~2.4.1",
        "cordova-plugin-whitelist": "~1.3.3",
        "ionic-angular": "~3.9.2",
        "ionic-plugin-keyboard": "~2.2.1",
        "ionicons": "~3.0.0",
        "query-string": "~4.3.4",
        "rxjs": "~5.5.10",
        "sw-toolbox": "~3.6.0",
        "zone.js": "~0.8.26"
    },
    "devDependencies": {
        "@ionic/app-scripts": "1.3.0",
        "typescript": "^2.8.1"
    },
0
Diego Malagón 13 Апр 2018 в 21:02

1 ответ

Лучший ответ

Мне удалось исправить это, обновив пакет @ ionic / app-scripts до 3.8.0 (последняя версия на тот момент) и добавив эту строку в index.html перед тем, как импортировать main.js

<script src="build/vendor.js"></script>

Я тоже обновил все пакеты, но думаю, что обновления app-script достаточно.

0
Diego Malagón 18 Апр 2018 в 15:41