Когда я пытаюсь обновить пакеты NuGet для своего решения, я получаю следующий набор ошибок, однако методы, которые я пробовал, не решили проблему. Может кто-нибудь объяснить, пожалуйста, и помочь мне решить эту проблему? Заранее спасибо.

Errors

0
Curiousity 27 Май 2017 в 21:29

2 ответа

Лучший ответ

Как сказал @daramasala в ответе, «последняя версия библиотеки поддержки - 25.3.1, то есть Android 7». В моем проекте Целевая версия Android уже было установлено на 7, но затем я также установил для Компилировать с использованием версии Android значение Android 7, и после этого я мог обновить пакеты NuGet без проблем.

Вы можете установить Целевую версию Android , Компилировать с использованием версии Android , а также Минимальную версию Android , перейдя в проект Свойства из раздела Приложение ....

Screenshot of the properties window

0
Curiousity 3 Июн 2017 в 01:20

Сообщение об ошибке объясняет проблему. Последняя версия библиотеки поддержки 25.3.1, то есть Android 7. Ваш проект нацелен на Android 6. Так что либо измените цель вашего проекта (в Project Options | General | Target framework) на 7 (или 7.1), либо используйте версию 23 поддержка библиотеки.

2
daramasala 28 Май 2017 в 05:14