Я пытаюсь создать логин / регистрацию, используя это руководство. Когда я запускаю authService, предоставленный ionic g, я получаю сообщение об ошибке TypeError: AppScripts.processProviderRequest не является функцией.

Я обновил node.js и мой ionic-angular до последней версии, но это не помогло.

global packages: 
@ionic/cli-utils : 1.2.0 
Ionic CLI : 3.2.0 

local packages: 
@ionic/app-scripts : 1.1.4 
@ionic/cli-plugin-ionic-angular : 1.2.0 
Ionic Framework : ionic-angular 3.3.0 

System: 
Node : v6.10.3 
OS : Windows 10 
Xcode : not installed 
ios-deploy : not installed 
ios-sim : not installed 

Пожалуйста помоги!

0
Ian Likono 28 Май 2017 в 05:43

2 ответа

Лучший ответ

Да, это сработало для меня, запустив приведенный ниже скрипт в cmd

npm install @ionic/app-scripts@latest

Пример: C:\Source\Examples\Ionic\NewWebApp\NewWebApp>npm install @ionic/app-scripts@latest

3
Arun Vinoth 29 Авг 2017 в 19:26

@ ionic / app-scripts: 1.1.4

Похоже, что ваши сценарии приложения имеют старую версию.

Обратитесь к package.json в начальном приложении код для его обновления. Это пакет, из которого загружается приложение при выполнении команды ionic start.

"@ionic/app-scripts": "1.3.7"

Вы также можете проверить любые другие проблемы с зависимостями, которые могут у вас возникнуть, в стартовом приложении.

2
Suraj Rao 28 Май 2017 в 04:10