Я только что обновил python и не могу заставить pandas работать должным образом, см. Ниже. Кажется, ничего не работает.

Отслеживание (последний вызов последним): файл "/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/tqdm/_tqdm.py", строка 613, в пандах из pandas.core. groupby.groupby import DataFrameGroupBy, \ ImportError: невозможно импортировать имя DataFrameGroupBy из pandas.core.groupby.groupby (/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/pandas /core/groupby/groupby.py)

Во время обработки вышеупомянутого исключения произошло другое исключение:

Отслеживание (последний вызов последним): Файл "code / analysis / get_cost_matrix.py", строка 23, в tqdm.pandas () # Предоставляет нам хорошие индикаторы выполнения. Файл "/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/tqdm/_tqdm.py", строка 616, в пандах from pandas.core.groupby import DataFrameGroupBy, \ ImportError: невозможно импортировать имя PanelGroupBy из pandas.core.groupby (/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/pandas/core/groupby/ init .py)

3
JAL 19 Дек 2019 в 07:20

2 ответа

Я полагаю, вы используете более старую версию tqdm. Попробуйте использовать версию выше tqdm> = 4.23.4.

Команда с использованием pip будет,

pip install tqdm --upgrade

3
shreyansh 19 Дек 2019 в 07:27
Похоже, проблема с tqdm и последней версией pandas
 – 
Simon O'Doherty
28 Янв 2020 в 12:20

Проблема в версии pandas 0.25.1. Рассмотрите возможность понижения его до 0.24.0. Для получения дополнительной информации прочтите это

pip install --upgrade pandas==0.24.0

0
paradocslover 9 Июн 2020 в 12:42