У меня установлен Python 3.6.5 и Python 3.7.4.

python --version

дает мне 3,6, а

python3 --version

дает мне 3.7. Запуск кода в PyCharm указывает, что он все еще использует 3.6. Как мне обновить его, чтобы начать использовать 3.7 и / или удалить 3.6?

Я просмотрел SO и другие форумы, но пока что, похоже, ничего не относилось к этой конкретной проблеме.

1
EnterPassword 21 Дек 2019 в 04:10

1 ответ

Лучший ответ

Если вы хотите сохранить ваши другие версии Python и хотите, чтобы PyCharm запускал ваш код в версии 3.7, вы можете просто перейти в настройки PyCharm и установить интерпретатор проекта на 3.7.

Вот вопрос переполнения стека, показывающий, как

Если вы не видите там интерпретатора Python, вы можете добавить его вручную перед установкой в настройках. Вот страница документа, которая может помочь

1
Yacine Mahdid 21 Дек 2019 в 01:52