У меня есть петля 3 приложения. Когда я запускаю приложение с . node, я получаю это в своей консоли.

hsts deprecated The "includeSubdomain" parameter is deprecated. Use "includeSubDomains" (with a capital D) instead. node_modules/loopback/lib/server-app.js:74:25

Я искал в своей папке node_modules, но нет петлевой папки. Так как я могу это исправить?

2
BlockchainProgrammer 28 Май 2019 в 11:12

2 ответа

Лучший ответ

Это связано с конфигурацией helmet в middleware.json. Просто откройте его, затем найдите и замените includeSubdomain на includeSubDomains.

7
Charlie VO 28 Май 2019 в 10:21

У меня тоже такая же ошибка, но просто просматриваю логи PM2, чтобы увидеть это.

Используете ли вы Loopback с PM2 или внутри контейнера Docker?

У меня нет этой ошибки с запуском "NODE".

0
Tristan Nguyen 28 Май 2019 в 09:57