Я уже около часа бью об этом кирпичную стену. У меня есть список округов, которые я создаю и добавляю к своим данным представления (округа), а затем визуализирую список с: html.DropDownList('invoice.county', counties) в моем представлении.

Кажется, он отображается правильно, но FF ОТКАЗЫВАЕТСЯ , чтобы установить выбранный элемент. Я попытался заменить значения целыми числами (чтобы они не соответствовали отображаемому тексту), и это не сработало. FF просто отображает первый элемент в списке

<select id="invoice_county" name="invoice.county">
   ...
   <option value="Lander">Lander</option>
   <option selected="selected" value="Laramie">Laramie</option>
   <option value="Larimer">Larimer</option>
   ...
</select>

Я обрезал значения до тех, которые окружают выбранный элемент.

Может ли кто-нибудь дать мне представление об этом ????

0
Andrew Burns 19 Мар 2009 в 01:35
Какая версия Firefox? Кажется, у меня нормально работает в 3.0.7. Кроме того, может быть на странице какой-нибудь скрипт, который все испортил?
 – 
Robin Clowers
19 Мар 2009 в 01:45

2 ответа

Лучший ответ

Если вы используете XHTML, вам нужна допустимая пара атрибут / значение:

<option selected="selected" value="x">

Если вы используете HTML, достаточно простого наличия атрибута:

<option selected value="x">

Дополнительная информация о W3C.

2
Fenton 23 Май 2018 в 12:23

У Firefox есть странная ошибка / функция, которая означает, что если вы просто обновите страницу, он выберет уже выбранный вариант независимо от того, находится ли выбранный атрибут в другом варианте. Например, если я введу:

<select id="invoice_county" name="invoice.county">
   <option value="Lander">Lander</option>
   <option selected="selected" value="Laramie">Laramie</option>
   <option value="Larimer">Larimer</option>
</select>

Сохраните и обновите в Firefox, затем поместите:

<select id="invoice_county" name="invoice.county">
   <option selected="selected" value="Lander">Lander</option>
   <option value="Laramie">Laramie</option>
   <option value="Larimer">Larimer</option>
</select>

Вместо этого и просто обновляясь после сохранения, он оставит выбранным "Laramie". Чтобы остановить это, попробуйте Ctrl-F5, а не просто F5 или обновление.

7
Francis Gilbert 19 Мар 2009 в 12:51
Вы также можете использовать autocomplete = off, чтобы не предлагать пользователям использовать Ctrl-F5.
 – 
Dave
26 Сен 2016 в 21:08