Возникла странная проблема с Microsoft Edge, не загружающим мой сайт Aurelia. Я гуглил часами безуспешно. Единственное решение Microsoft - очистить кеш или выполнить sfc / scannow. Если у меня открыты инструменты разработчика, страница пытается загрузиться, но через несколько секунд я получаю тот же результат.

Я опубликовал этот сайт здесь: https://jbockle.github.io/aurelia -json - схема - форма /

Я получаю следующую ошибку перенаправления:

У этой страницы проблемы с загрузкой

Мы несколько раз пытались загрузить эту страницу для вас, но проблема с этим сайтом все еще существует. Мы знаем, что у вас есть дела поважнее, чем наблюдать за перезагрузкой этой страницы снова и снова, поэтому попробуйте вернуться на эту страницу позже.

Мне нужно подтвердить, что эта проблема возникла не только у меня, и если у вас есть какие-либо советы по ее решению.

Мой проект с открытым исходным кодом здесь: https://github.com/jbockle/aurelia-json -schema -форма

1
jbockle 23 Сен 2018 в 00:43

2 ответа

Лучший ответ

Проблема оказалась в элементе <input type="range"> с атрибутом placeholder.bind, который я скопировал из другого моего шаблона. По какой-то причине это привело к сбою microsoftedgecp.exe. Удаление атрибута исправило его.

1
jbockle 25 Сен 2018 в 00:03

Вы используете в своем проекте медиа-запрос -ms-viewport?

Когда я пытаюсь открыть вашу страницу в Edge, я получаю предупреждение ниже.

enter image description here

Вы можете попробовать удалить его из своего проекта, это может помочь вам решить эту проблему. Похоже, что -ms-viewport больше не поддерживается Edge.

Если вы запускаете страницу в Chrome, страница загружается, но в консоли также возникает ошибка 404.

0
Deepak-MSFT 24 Сен 2018 в 02:47