Я купил онлайн-приложение для облачного хранения и обмена файлами. И я загрузил его на свой vps-сервер. Конфигурация сервера - 2-ядерный процессор и 4 ГБ оперативной памяти. Мое веб-приложение написано на php и laravel. Я разместил это веб-приложение на моем vps-сервере. И попробуй закачать файл. Первый загруженный мной файл размером 25 МБ был успешно загружен. Но я пытаюсь загрузить файл размером до 312 МБ, но он не может загрузить. Иногда он загружается, а иногда не удается. Почему так случилось? Я изменил некоторые параметры в php.ini

max_file_size = 1024MB
post_file_size = 1024MB
memory = 512MB
max_execution_time = 500000
max_input_time = 50000

У меня монитор сервера, монитор не использовал больше памяти. Buf-файл несколько раз загружается или иногда не может быть загружен. Это происходит, если я загружаю файл размером более 100 МБ.

Кто-нибудь скажет мне, почему это произошло? Это случилось из-за моего интернета? Но если я загружу 500 МБ на диск Google через Интернет, он будет успешно загружен.

0
Divyesh Prajapati 20 Окт 2019 в 14:28

2 ответа

Вы уверены, что изменили правильный файл php.ini в соответствии с вашей активной версией php и выбранным php-fpm / php-cli?

0
Adventure Searcher 20 Окт 2019 в 14:36
Я уверен, что изменил эти параметры в /etc/php.ini.
 – 
Divyesh Prajapati
20 Окт 2019 в 14:42
Привет, @AdventureSearcher, добро пожаловать в SO, пожалуйста, используйте раздел комментариев, чтобы получить разъяснения по вопросам, также посмотрите это (stackoverflow. ru / help / how-to-answer) :)
 – 
Sammy J
20 Окт 2019 в 14:45
Привет, уверен в изменениях. я изменил max_uploading_file и post_uploading. если я изменю memory = -1, то это будет неограниченно? И что я могу сделать, чтобы unmeter max_execution time и max_post_time?
 – 
Divyesh Prajapati
20 Окт 2019 в 15:04
@ sammy-j Я не могу использовать разделы комментариев, потому что моя репутация ниже 50
 – 
Adventure Searcher
22 Окт 2019 в 11:36

Для увеличения максимального размера загружаемого файла обычно необходимо изменить в php.ini две вещи:

; Maximum allowed size for uploaded files.
; http://php.net/upload-max-filesize
upload_max_filesize = 1024M

А также

; Maximum size of POST data that PHP will accept.
; Its value may be 0 to disable the limit. It is ignored if POST data reading
; is disabled through enable_post_data_reading.
; http://php.net/post-max-size
post_max_size = 1024M

Дополнительно проверьте значение memory_limit, так как оно также может повлиять на максимально возможный размер загружаемых файлов:

; Maximum amount of memory a script may consume (128MB)
; http://php.net/memory-limit
memory_limit = 128M

Не забудьте перезапустить HTTP-сервер после сохранения изменений, чтобы новая конфигурация вступила в силу.

Названия параметров, которые вы указали в своем вопросе, кажутся неправильными. Присутствовали ли они в вашем php.ini с другими назначенными значениями или вы просто добавили их в файл?

0
mario 20 Окт 2019 в 15:45