Google Play отклоняет мою заявку из-за версии Cordova, которую я использую:

Apache Cordova
The vulnerabilities were fixed in Apache Cordova v.4.1.1 or higher.

You can find information about how to upgrade in this Google Help Center article.

Я обновился до Cordova 4.1.1 и все еще получаю эту ошибку при загрузке новой сборки.

$ cordova -v
6.4.0

$ cordova platform ls
Installed platforms:
  android 4.1.1

Кто-нибудь знает, как исправить эту проблему?

1
Tiois 11 Янв 2017 в 00:38

1 ответ

Лучший ответ

Проблема была довольно простой: Google Play отказался от сборки, которую я отправил в производство с Cordova 3.5.0. С этого момента при каждой отправленной мной сборке Alpha Google Play жаловался на мою производственную сборку, в которой использовалась Cordova 3.5.0. Единственный способ решить эту проблему - отправить сборку в Alpha и переместить ее в Production, не имея возможности протестировать ее в режиме Alpha через Google Play. К сожалению, мы не можем протестировать какую-либо сборку в магазине Google Play в Alpha или Beta, когда есть сборка с проблемой безопасности в Production.

Надеюсь, это поможет некоторым людям с этой странной проблемой.

0
Tiois 16 Янв 2017 в 23:01