Кто-то уже пытался использовать это https://github.com/CanHub/Android-Image-Cropper библиотека? не могли бы прислать свой собственный гитхаб или объяснить мне, как настроить. Я настроился, но всегда терпел неудачу. потому что я пытался настроить эту библиотеку но во время синхронизации gradle я всегда получаю сбой сборки.

Пожалуйста, без запугивания и ненависти

Execution failed for task ':app:mergeDebugNativeLibs'.
> Could not resolve all files for configuration ':app:debugRuntimeClasspath'.
   > Could not find com.github.CanHub:Android-Image-Cropper:3.3.4.
     Searched in the following locations:
       - https://dl.google.com/dl/android/maven2/com/github/CanHub/Android-Image-Cropper/3.3.4/Android-Image-Cropper-3.3.4.pom
       - https://repo.maven.apache.org/maven2/com/github/CanHub/Android-Image-Cropper/3.3.4/Android-Image-Cropper-3.3.4.pom
       - https://jcenter.bintray.com/com/github/CanHub/Android-Image-Cropper/3.3.4/Android-Image-Cropper-3.3.4.pom
     Required by:
         project :app

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
==============================================================================

* Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 8.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/7.0.2/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 1s
19 actionable tasks: 18 executed, 1 up-to-date

Из-за обновления ArctixFox Android Studio allproject {repositories} больше не существует maven { url 'https://jitpack.io' }, почему я должен добавить это

1
Baish Masirov 18 Ноя 2021 в 11:15

1 ответ

Лучший ответ

Судя по полученной вами ошибке, похоже, что Gradle не может разрешить зависимость CanHub. Скорее всего, это связано с тем, что вы не включили репозиторий jitpack в build.gradle вашего проекта (а не в модуль build.gradle).

Чтобы добавить jitpack в репозитории, добавьте maven { url 'https://jitpack.io' } на уровень вашего проекта build.gradle

buildscript {
     repositories {
       ....
       maven { url 'https://jitpack.io' }
     }
  }
0
Praveen 18 Ноя 2021 в 11:34
Спасибо, но. 'allprojects {repositories {.... maven {url' jitpack.io '}}} больше не существует в ArcticFox. AndroidStudio. поэтому я не знаю, где добавить maven
 – 
Baish Masirov
18 Ноя 2021 в 11:37
Я обновил свой ответ
 – 
Praveen
18 Ноя 2021 в 11:38