Мне нужно разработать весенний проект. Требования следующие:

  • Весна - 3,0
  • Гибернация - 3.0
  • MySql 5.5
  • Tomcat 6.0
  • JDK 1,7

Я не использую web.xml, вместо этого я использую конфигурацию java. Когда я пытаюсь запустить свой проект на Tomcat v6.0 (щелкнув правой кнопкой мыши в eclipse в проекте -> Выполнить на сервере), он говорит, что этот проект может не запускаться ни на одном сервере. Я понятия не имею, как запустить этот проект. Мой pom.xml выглядит следующим образом:

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>lab.testme</groupId>
<artifactId>test</artifactId>
<version>0.0.1-SNAPSHOT</version>
<packaging>war</packaging>
<name>testme3.0</name>
<properties>
<maven.compiler.source>1.7</maven.compiler.source>
<maven.compiler.target>1.7</maven.compiler.target>
</properties>
<dependencies>
<dependency>
    <groupId>org.springframework</groupId>
    <artifactId>spring-webmvc</artifactId>
    <version>3.2.13.RELEASE</version>
</dependency>
<dependency>
    <groupId>javax.servlet</groupId>
    <artifactId>jstl</artifactId>
    <version>1.2</version>
</dependency>
<dependency>
    <groupId>javax.servlet</groupId>
    <artifactId>javax.servlet-api</artifactId>
    <version>3.1.0</version>
    <scope>provided</scope>
</dependency>
<dependency>
    <groupId>org.apache.tiles</groupId>
    <artifactId>tiles-extras</artifactId>
    <version>3.0.3</version>
</dependency>
<dependency>
    <groupId>org.slf4j</groupId>
    <artifactId>slf4j-api</artifactId>
    <version>1.7.5</version>
</dependency>
<dependency>
    <groupId>mysql</groupId>
    <artifactId>mysql-connector-java</artifactId>
    <version>5.1.32</version>
    <scope>runtime</scope>
</dependency>
<dependency>
    <groupId>org.codehaus.jackson</groupId>
    <artifactId>jackson-mapper-asl</artifactId>
    <version>1.5.3</version>
</dependency>
<dependency>
    <groupId>org.codehaus.jackson</groupId>
    <artifactId>jackson-core-asl</artifactId>
    <version>1.5.3</version>
</dependency>
<dependency>
    <groupId>com.fasterxml.jackson.core</groupId>
    <artifactId>jackson-databind</artifactId>
    <version>2.5.1</version>
</dependency>
<dependency>
    <groupId>org.springframework.security</groupId>
    <artifactId>spring-security-web</artifactId>
    <version>3.0.8.RELEASE</version>
</dependency>
<dependency>
    <groupId>org.springframework.security</groupId>
    <artifactId>spring-security-config</artifactId>
    <version>3.0.8.RELEASE</version>
</dependency>
<dependency>
    <groupId>org.springframework</groupId>
    <artifactId>spring-jdbc</artifactId>
    <version>3.0.5.RELEASE</version>
</dependency>
<dependency>
    <groupId>org.springframework</groupId>
    <artifactId>spring-orm</artifactId>
    <version>3.0.5.RELEASE</version>
</dependency>
<dependency>
    <groupId>com.fasterxml.jackson.core</groupId>
    <artifactId>jackson-annotations</artifactId>
    <version>2.5.1</version>
</dependency>
<dependency>
    <groupId>org.hibernate</groupId>
    <artifactId>hibernate-core</artifactId>
    <version>3.6.10.Final</version>
</dependency>
<dependency>
    <groupId>org.javassist</groupId>
    <artifactId>javassist</artifactId>
    <version>3.18.2-GA</version>
</dependency>
<dependency>
    <groupId>org.apache.tomcat</groupId>
    <artifactId>tomcat-dbcp</artifactId>
    <version>7.0.55</version>
</dependency>
<dependency>
    <groupId>javax.validation</groupId>
    <artifactId>validation-api</artifactId>
    <version>1.1.0.Final</version>
</dependency>
<dependency>
    <groupId>org.hibernate</groupId>
    <artifactId>hibernate-validator</artifactId>
    <version>4.1.0.Final</version>
</dependency>
<dependency>
    <groupId>org.hibernate</groupId>
    <artifactId>hibernate-entitymanager</artifactId>
    <version>4.3.5.Final</version>
</dependency>
<dependency>
    <groupId>org.springframework</groupId>
    <artifactId>spring-tx</artifactId>
    <version>3.2.2.RELEASE</version>
</dependency>
</dependencies>
<build>
<plugins>
    <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-war-plugin</artifactId>
        <version>2.6</version>
        <configuration>
            <failOnMissingWebXml>false</failOnMissingWebXml>
        </configuration>
    </plugin>
</plugins>
</build>
</project>

Мои параметры настройки следующие: -

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
  <fixed facet="wst.jsdt.web"/>
  <installed facet="wst.jsdt.web" version="1.0"/>
  <installed facet="java" version="1.7"/>
  <installed facet="jst.web" version="3.1"/>
</faceted-project>

Я просмотрел несколько статей и попытался изменить jst.web на 2.4 вместо 3.1, но это не работает. Если я пытаюсь отредактировать Project Facets через eclipse, это дает мне ошибку как Can not change version of project facet dynamic web module to 2.5. Пожалуйста, подскажите, как запустить этот проект?

-1
vishal 29 Июн 2016 в 13:14
Вы даже не упомянули, как вы запускаете свой проект. Похоже, вы используете интеграцию Tomcat в своей среде IDE.
 – 
kryger
29 Июн 2016 в 13:25
: Я запускаю свой проект, щелкнув правой кнопкой мыши проект в eclipse -> Выполнить на сервере. Затем он показывает мне диалоговое окно для выбора сервера, когда я пытаюсь выбрать v6.0, тогда я получил ошибку выше
 – 
vishal
29 Июн 2016 в 13:29
2
Обратите внимание, что tomcat 6, а также spring 3.2 выйдут на eol в конце этого года, и вы, возможно, больше не будете получать важные обновления безопасности, как только ваш проект будет запущен.
 – 
zapl
29 Июн 2016 в 13:36
2
Tomcat 6 - это контейнер сервлета 2.5, для которого требуется файл web.xml. По крайней мере, вам нужно, чтобы tomcat 7 работал без web.xml. Еще одна вещь, в которой ваши зависимости - беспорядок, вы смешиваете несколько версий Spring (и, возможно, также спящий режим), никогда не смешиваете jar-файлы с версиями фреймворка, это неизбежно вызывает проблемы. См. tomcat.apache.org/whichversion.html.
 – 
M. Deinum
29 Июн 2016 в 13:36
: да, я читал об этом, но моя компания не заботится об этом, поэтому я должен построить его с указанной выше конфигурацией
 – 
vishal
29 Июн 2016 в 13:37

1 ответ

Лучший ответ

Конфигурация на основе Java для Интернета (с использованием ServletContainerInitializer, который, в свою очередь, для Spring будет использовать WebApplicationInitializer) - это функция Servlet 3.0. Tomcat 6 поддерживает спецификацию Servlet 2.5 и, как таковой, не поддерживает конфигурацию на основе Java. Короче говоря, при использовании Tomcat 6 вы ДОЛЖНЫ использовать web.xml. См. this для получения информации о том, какая спецификация сервлета поддерживается какой версией Tomcat.

Чтобы исправить, либо обновитесь до Tomcat 7, либо используйте web.xml.

1
M. Deinum 29 Июн 2016 в 13:54