Я хочу объединить 2 модуля в своем проекте. Один :

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '8.0'
use_frameworks!

pod 'DJKFlipper'

А другой:

platform :ios, '9.0'
pod 'HQPagerViewController', :git=> 'https://github.com/quangpc/HQPagerViewController.git', :branch=> 'master'

Проблема в том, что один запрашивает платформу 8.0, а другой - 9.0.

Я попытался изменить всю файловую платформу на 8.0, но получил следующую ошибку: Specs satisfying the HQPagerViewController (from https://github.com/quangpc/HQPagerViewController.git, branch master), HQPagerViewController (= 1.0) dependency were found, but they required a higher minimum deployment target.

И если сохранить цель на 9.0, у меня будет более 100 проблем в приложении после установки модуля, поскольку целевая платформа неверна.

Я тоже пробовал это:

target 'Bhaskar' do
  # Comment the next line if you're not using Swift and don't want to use dynamic frameworks

 platform :ios, ‘9.0’
  use_frameworks!

  pod 'HQPagerViewController', :git=> 'https://github.com/quangpc/HQPagerViewController.git', :branch=> 'master'

end

target 'Bhaskar - FlipView’ do
  source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '8.0'
use_frameworks!

pod 'DJKFlipper'
end

Но и здесь возникает ошибка. Я использовал поды, может быть, второй раз, и всегда работал с одной и той же платформой. Как я могу совместить и то, и другое?

Любая помощь будет оценена! Благодарность!

1
Mamta 9 Июл 2017 в 18:48

2 ответа

Это потому, что ваша «Цель развертывания» в настройках вашего проекта ниже 9.0 (что является минимумом, требуемым HQPagerViewController), поэтому вам придется изменить это на 9.0. введите описание изображения здесь

0
RJiryes 9 Июл 2017 в 19:48
Но платформа для одного модуля - 8,0, а для другого - 9,0.
 – 
Mamta
9 Июл 2017 в 19:59

Поскольку у вас есть минимальное требование ios 9 для одного модуля, ваша целевая платформа должна быть 9. Вы можете изменить цель развертывания, как упомянул RJiryes выше. Так как один из ваших модулей имеет базу 8, в большинстве случаев он должен поддерживать iOS от 9 до. Но в случае, если ваш модуль ios 8 имеет устаревший код по сравнению с ios 9, в этом случае вам придется свернуть свой модуль и изменить его для поддержки ios9. И важно, чтобы вы использовали последние версии модулей, так как использование более старых версий модулей не является хорошей практикой и может привести к проблемам.

0
Gihan 9 Июл 2017 в 20:11