У меня вопрос, какую версию мне следует использовать? Я начал с Symfony 3.4 LTS, для которой требуется FOSUserBundle ^ 2.0. Чтобы использовать SonataUserBundle с FOSUserBundle, мне нужно использовать ^ 4.0. В 4.0 нет профилей пользователей. Мне нужно их все реализовать или я что-то упустил?

1
NotI.mportant 2 Янв 2018 в 17:55

2 ответа

Лучший ответ

Есть только один способ использовать SonataUserBundle версии 4.x-dev, но ... со специальной ссылкой на фиксацию (3dd68a6aae95cffe6a4275d68c27d2766d8b93f7) и FosUserBundle версии 2.0.1. Я точно знаю, что это работает для Symfony 3.3.2

Вот пример composer.json и composer.lock:

< Сильный > Composer.json

"require": {

    ...

    "friendsofsymfony/user-bundle": "v2.0.1",

    ...

    "sonata-project/admin-bundle": "3.18.2",
    "sonata-project/doctrine-orm-admin-bundle": "3.1.4",
    "sonata-project/user-bundle": "4.x-dev",

    ...

    "symfony/symfony": "^3.3.2",

    ...

},

Compose.lock (часть пользовательского пакета сонаты)

 {
        "name": "sonata-project/user-bundle",
        "version": "dev-master",
        "source": {
            "type": "git",
            "url": "https://github.com/sonata-project/SonataUserBundle.git",
            "reference": "3dd68a6aae95cffe6a4275d68c27d2766d8b93f7"
        },
        "dist": {
            "type": "zip",
            "url": "https://api.github.com/repos/sonata-project/SonataUserBundle/zipball/3dd68a6aae95cffe6a4275d68c27d2766d8b93f7",
            "reference": "3dd68a6aae95cffe6a4275d68c27d2766d8b93f7",
            "shasum": ""
        },
 ...
1
staskrak 4 Янв 2018 в 10:28

Чтобы использовать SonataUserBundle 4.x с Symfony 3.4 (и более конкретно с PHP 5.6 / 7.0), вы можете использовать "runroom/sonata-user": "4.x-dev" (см. https://github.com/Runroom/SonataUserBundle ), который является форком одного из членов команды Sonata для восстановления совместимости PHP 5.6 / 7.0 для SonataUserBundle.

0
gnutix 2 Май 2018 в 09:36