Используйте для вопросов об установщике пакета Python

Подробнее про pip...

Я пытаюсь установить Atlas Plots, но получаю некоторые ошибки. Я попытался установить его с помощью следующей командной строки: pip3 install https://github.com/joeycarter/atlas-plots Но когда я запускаю его, терминал показывает мне следующую ошибку: Не удается определить формат архива / tmp / pip-....
3 Май 2021 в 00:33
Я хочу установить Numpy на PyPy в Windows, но не могу. Вот мои ошибки: ERROR: Command errored out with exit status 1: command: 'C:\pypy3.7-v7.3.4-win64\pypy3.exe' 'C:\pypy3.7-v7.3.4-win64\site-packages\pip\_vendor\pep517\in_process\_in_process.py' prepare_metadata_for_build_wheel 'C:\Users\myp....
2 Май 2021 в 17:55
В Dockerfile, где мы создаем образ для наших проектов python, у нас есть такая строка для обновления pip до последней версии: RUN pip install --upgrade pip Некоторое время это работало хорошо, но недавно сборка образа начала давать сбой, потому что мы используем python 3.6.1, а последняя версия pip....
30 Апр 2021 в 11:13
У меня проблема с Heroku и Pillow. Я разработал приложения с django, и у меня есть столбцы с ImageField. Во время работы в heroku у меня появляется сообщение об ошибке для установки подушки с помощью pip. Сообщение об ошибке: product.Profile.image: (fields.E210) Cannot use ImageField because Pillow ....
29 Апр 2021 в 11:33
Я работаю над проектом, в котором вам нужно будет распаковать архив со всеми данными и все будет работать, без установки пакетов пользователем. Пришел к созданию бота Discord, но он выдает ошибку, не понимаю, что с этим связано. Traceback (most recent call last): File "path\Project Folder\bot.py"....
28 Апр 2021 в 09:43
Я пытаюсь использовать скрипт Python 3, для которого требуется модуль neo4j. Я уже установил модуль в python 3, но при повторной попытке запустить скрипт он продолжает запрашивать модуль. При попытке запустить программу, требующую модуля neo4j: c:\Users\user1\Downloads\PlumHound-master>python3 Plum....
27 Апр 2021 в 22:33
Выполнение команды дает мне следующую ошибку: C: \ Python34 \ Scripts> pip install pygame Стек ошибок: Traceback (most recent call last): File "C:\Python34\lib\runpy.py", line 171, in _run_module_as_main "__main__", mod_spec) File "C:\Python34\lib\runpy.py", line 86, in _run_code exec(....
27 Апр 2021 в 09:32
MacOS Big Sur 11.2.3, python 2.7. Я запускаю sudo easy_install pip, чтобы установить pip, затем запускаю pip install prettytable, наконец, я получил ошибки ниже, любой может помочь ~ Traceback (most recent call last): File "/usr/local/bin/pip", line 11, in <module> load_entry_point('pip==21.0.....
27 Апр 2021 в 05:53
Я работаю над контейнеризацией своего приложения Flask с помощью докера, и при запуске получаю следующую ошибку: docker-compose build Приложение отлично работает на моем локальном компьютере. Я пробовал обновить pip, используя brew для удаления / переустановки Libxmlsec1 и pkg-config, а также испол....
27 Апр 2021 в 05:36
Итак, я пытаюсь установить Perceptilabs, чтобы иметь графический интерфейс для TensorFlow. Я следую их инструкциям по установке: pip install perceptilabs. Однако у меня все еще возникает ошибка: ОШИБКА: не удалось найти версию, удовлетворяющую требованию perceptilabs. ОШИБКА: не найдено подходящег....
23 Апр 2021 в 12:38
Я использовал модуль mathutils для проекта в Linux и хотел запустить проект в Windows. Проблема в том, что я получаю эту ошибку при попытке установить модуль mathutils в Windows: (версия python: 3.9 ........
23 Апр 2021 в 10:58
Так что у меня есть MacBook Air с 11.2.1 Big Sur pip --version Возвращает этот вывод: pip 20.2.1 from /Library/Python/2.7/site-packages/pip-20.2.1-py2.7.egg/pip (python 2.7) Когда я ввожу python в терминал, он автоматически загружает python 2.7, а python3 загружает python 3.8.2, как и предполагало....
20 Апр 2021 в 22:17
Лучшие практики Dockerfile дают следующие рекомендации по использованию обновления apt-get: Всегда объединяйте RUN apt-get update с apt-get install в одном операторе RUN. Должен ли я также использовать то же самое .......
19 Апр 2021 в 18:14
Я работаю над Ptera Software, решателем аэродинамики с открытым исходным кодом. Это первый распространенный мной пакет, и у меня возникли некоторые проблемы, связанные с управлением памятью. В частности, импорт моего пакета занимает абсурдное количество памяти. В последний раз, когда я проверял, п....
19 Апр 2021 в 10:20
Я попробовал все три решения из этого вопроса, чтобы решить проблему, но все равно получаю сообщение об ошибке : ImportError: cannot import name 'ToTensorV2' from 'albumentations.pytorch' (/usr/local/lib/python3.7/dist-packages/albumentations/pytorch/__init__.py) Мой текущий код: !pip install -U a....
18 Апр 2021 в 21:36
При преобразовании кода Python в exe с помощью pyinstaller он не находит некоторые модули, которые я установил, поэтому программа не запускается на других ПК. Все плагины показаны ниже: import getpass import os.path import random import smtplib import ssl import time import keyboard import psutil fr....
18 Апр 2021 в 20:00
При создании новой среды venv в новом проекте я набираю в командной строке: '' 'python -m venv new_prj' '' После этого я устанавливаю какой-то модуль pip '' 'pip install django == 2' '' - например и он автоматически изменяет все мои другие проекты на venv и устанавливает этот '' 'django ==....
17 Апр 2021 в 23:07
Я пробовал conda remove nodejs и pip uninstall nodejs, но это не сработало. Я получаю это сообщение об ошибке PackagesNotFoundError: The following packages are missing from the target environment: - nodejs Но когда я использую conda search nodejs. Оказывается, пакет все еще существует. ....
17 Апр 2021 в 22:13
Я пытаюсь установить модуль python-shout в Windows 10, но это не удается. В убунту работает хорошо. Файл shout.c (изменен) #define PY_SSIZE_T_CLEAN #include <Python.h> #include <shout/shout.h> #define PyString_Check(m) PyUnicode_Check(m) #define PyString_AsString(m) PyBytes_AS_STRING((PyObject*)....
16 Апр 2021 в 17:59
У меня проблема с установкой библиотек с помощью pip install .whl Это информация о моей среде: conda version : 4.10.1 conda-build version : 3.20.5 python version : 3.8.5.final.0 virtual packages : __cuda=10.2=0 Моя ОС - Windows 10 Я загрузил файл whl с этого веб-сайта, как и раньше показано в этом ....
16 Апр 2021 в 03:17
Почти вчера я видел странную проблему, когда при запуске простой сборки jenkins, использующей шаблон pod с докером контейнера: 18.09.6-dind (alpine linux), сборка завершалась ошибкой при попытке установить awscli с помощью pip. Вот пример кода: - apk add curl apk add py-pip pip install --user aws....
15 Апр 2021 в 20:47
Я уже ссылался на эти сообщения 1, 2, 3 , 4, 5 Но я все еще не могу исправить эту проблему. Может быть, потому, что другие вопросы слишком технические. Я сделал ниже А) Я запустил блокнот jupyter (сохраните файл на рабочем столе) Б) Импортированные обычные пакеты, такие как Pandas, Numpy, Scipy и т....
15 Апр 2021 в 16:37
Раньше, когда я устанавливал свой локальный пакет, его правильный путь отображался, когда я отправляю список Поэзия старых версий: 1.0.2 Список пипсов package version location ---------- --------- ------------....
15 Апр 2021 в 07:52
Я использую версию кода Visual Studio 1.55.2, версию pip для виртуальной среды 21.0.1 и версию Python 3.8.9. Когда я делаю pip install pyodbc, в моей папке .venv/lib/python3.8/site-packages есть только папка pyodbc-4.0.30.dist-info. Для других пакетов у меня есть два, например, у меня есть папка a....
14 Апр 2021 в 14:03
Я использую Python 3 в Linux Когда я открываю новый терминал, имя виртуальной среды не отображается. Я могу установить пакеты Python в этой (неизвестной) среде с помощью pip install Как называется эта текущая виртуальная среда? Как я могу получить репозиторий, который эта виртуальная среда используе....
13 Апр 2021 в 14:48